summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Whitt2017-05-01 11:49:32 -0400
committerAlex Whitt2017-05-01 11:49:32 -0400
commit96209fc946c1894fedda63ca55cea32e1fe362ab (patch)
treeb4356c81f9db751be916d10c59fb6b85ec47c600
downloadaur-96209fc946c1894fedda63ca55cea32e1fe362ab.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c91043454b20
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon May 1 15:49:25 UTC 2017
+pkgbase = emacs-evil-iedit-state
+ pkgdesc = Slick Evil states for iedit.
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/syl20bnr/evil-iedit-state
+ arch = any
+ license = GPL3
+ depends = emacs
+ depends = emacs-iedit
+ optdepends = emacs-expand-region: Integration with expand-region
+ source = https://github.com/syl20bnr/evil-iedit-state/archive/v1.1.tar.gz
+ sha256sums = SKIP
+
+pkgname = emacs-evil-iedit-state
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06d8f9826d11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+
+pkgname=emacs-evil-iedit-state
+pkgver=1.1
+pkgrel=1
+pkgdesc="Slick Evil states for iedit."
+arch=(any)
+url="https://github.com/syl20bnr/evil-iedit-state"
+license=('GPL3')
+depends=('emacs' 'emacs-iedit')
+optdepends=('emacs-expand-region: Integration with expand-region')
+source=("https://github.com/syl20bnr/evil-iedit-state/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/evil-iedit-state-${pkgver}"
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd "${srcdir}/evil-iedit-state-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/emacs/site-lisp/evil-iedit-state/"
+ install -m644 *.el{c,} "${pkgdir}/usr/share/emacs/site-lisp/evil-iedit-state/"
+}