summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-19 01:26:58 -0500
committerLuis Martinez2021-10-19 01:26:58 -0500
commit963923c5afca1c9957de06e205e900744bfcabdc (patch)
treeca1216cf31725cf127428033b108acd02050b19e
downloadaur-963923c5afca1c9957de06e205e900744bfcabdc.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
-rw-r--r--crates.install9
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b95e5e72eeaf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = neovim-crates-git
+ pkgdesc = Neovim plugin that manages crates.io dependencies
+ pkgver = r108.ab2c491
+ pkgrel = 1
+ url = https://github.com/saecki/crates.nvim
+ install = crates.install
+ arch = any
+ groups = neovim-plugins
+ license = unknown
+ makedepends = git
+ provides = neovim-crates
+ provides = neovim-cmp-crates
+ conflicts = neovim-crates
+ conflicts = neovim-cmp-crates
+ source = neovim-crates-git::git+https://github.com/saecki/crates.nvim
+ md5sums = SKIP
+
+pkgname = neovim-crates-git
+ depends = neovim
+ depends = neovim-plenary
+ depends = cargo
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ded213021065
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-crates-git
+pkgver=r108.ab2c491
+pkgrel=1
+pkgdesc="Neovim plugin that manages crates.io dependencies"
+arch=('any')
+url="https://github.com/saecki/crates.nvim"
+license=('unknown')
+groups=('neovim-plugins')
+makedepends=('git')
+provides=("${pkgname%-git}" 'neovim-cmp-crates')
+conflicts=("${pkgname%-git}" 'neovim-cmp-crates')
+install=crates.install
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ depends=('neovim' 'neovim-plenary' 'cargo')
+
+ cd "$pkgname"
+ find after lua plugin -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/crates.install b/crates.install
new file mode 100644
index 000000000000..6a717885251c
--- /dev/null
+++ b/crates.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-crates-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}