summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitlab CI Runner2020-04-27 08:11:08 +0000
committerGitlab CI Runner2020-04-27 08:11:08 +0000
commit964b8dbba18153c97c37216153968a05121b8ec2 (patch)
tree4ec649901e2a64f781ce95ad20513f60d8868800
parent08ab1412e44feb0160589cbc34505375eb48fe2d (diff)
downloadaur-964b8dbba18153c97c37216153968a05121b8ec2.tar.gz
Updated package to exec-helper commit f91fa90b36433371e0dc606de550929914ecd4af
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
-rw-r--r--exec-helper.changelog23
3 files changed, 29 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5f24f2db732..0716798a1ee0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = exec-helper
pkgdesc = How To Get Coffee In Peace: a shell meta-wrapper
- pkgver = 0.4.1_16_gff7308c
+ pkgver = 0.5.0_0_g4571947
pkgrel = 1
url = https://github.com/bverhagen/exec-helper
changelog = exec-helper.changelog
@@ -20,7 +20,7 @@ pkgbase = exec-helper
makedepends = lsb-release
depends = yaml-cpp
depends = boost-libs
- source = exec-helper::git+https://github.com/bverhagen/exec-helper.git#commit=ff7308c5d412ce4d2fddd2844ced0fb8eb72879f
+ source = exec-helper::git+https://github.com/bverhagen/exec-helper.git#commit=457194703c49bc2982cc68c671ed4831285fe03c
md5sums = SKIP
pkgname = exec-helper
diff --git a/PKGBUILD b/PKGBUILD
index 9a3d18151b75..30f2398352e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bart Verhagen <barrie.verhagen@gmail.com>
pkgname=('exec-helper' 'exec-helper-docs')
pkgbase='exec-helper'
-pkgver=0.4.1_16_gff7308c
+pkgver=0.5.0_0_g4571947
pkgrel=1
epoch=
pkgdesc="How To Get Coffee In Peace: a shell meta-wrapper"
@@ -20,7 +20,7 @@ backup=()
options=()
install=
changelog=exec-helper.changelog
-source=('exec-helper::git+https://github.com/bverhagen/exec-helper.git#commit=ff7308c5d412ce4d2fddd2844ced0fb8eb72879f')
+source=('exec-helper::git+https://github.com/bverhagen/exec-helper.git#commit=457194703c49bc2982cc68c671ed4831285fe03c')
noextract=()
validpgpkeys=()
@@ -34,7 +34,7 @@ pkgver() {
build() {
_system_description=$(lsb_release --description --short | sed 's/"//g')
- _source_version=0.4.1_16_gff7308c
+ _source_version=0.5.0_0_g4571947
_release_version="($_system_description) $_source_version"
_copyright="Copyright (c) $(date +'%Y') Bart Verhagen"
@@ -47,16 +47,10 @@ build() {
}
check() {
- # It only makes sense to run the complete 'system test suite' (called integration by exec-helper devs) here
- _exec_helper_test_targets=('integration' 'execution-content' 'docs-man-integration')
-
- # Only define the cmake settings on top of the ones defined in build()
- cmake -H"$_git_dir" -B"$_build_dir" -DUSE_SYSTEM_CATCH=ON -DUSE_SYSTEM_RAPIDCHECK=ON -DENABLE_TESTING=ON -DENABLE_WERROR=OFF
- make --directory "$_build_dir" --jobs ${_nb_of_cores} ${_exec_helper_test_targets[@]}
-
_install_dir="$pkgdir/usr/"
- cd $_build_dir
- PATH="${PWD}/src/applications:${PWD}/test/base-utils/application/:$PATH" "test/integration/exec-helper-integration-test"
+ $_build_dir/src/applications/exec-helper --help 2>/dev/null | grep --silent 'Usage'
+ $_build_dir/src/applications/exec-helper --version 2>/dev/null | grep --silent 'exec-helper'
+ $_build_dir/src/applications/exec-helper --list-plugins "--additional-search-path=$_git_dir/src/plugins/src/scripts" 2>/dev/null | grep --silent 'make.lua'
}
package_exec-helper() {
diff --git a/exec-helper.changelog b/exec-helper.changelog
index 307e0dc8703a..3480711801a6 100644
--- a/exec-helper.changelog
+++ b/exec-helper.changelog
@@ -2,8 +2,27 @@ Changelog
=========
-0.4.1_16_gff7308c
-------------
+0.5.0 (2020-04-25)
+------------------
+
+New
+~~~
+- Usr: Added some more documentation on shell auto-completion. [Bart
+ Verhagen]
+- Usr: Added Bash and Zsh auto-completion support. [Bart Verhagen]
+- Usr: Changed copyright in the documentation to the BSD 3-clause.
+ Upgraded the end year of the copyright to this year. [Bart Verhagen]
+- Usr: Added the custom plugins as a major way to do more advanced
+ workflow optimization. [Bart Verhagen]
+- Usr: The PWD environment variable is set to the actual working
+ directory of a task. [Bart Verhagen]
+- Usr: Added documentation on writing custom plugins. [Bart Verhagen]
+- Usr: Added --list-plugins option for listing all available plugins.
+ [Bart Verhagen]
+
+
+0.4.2 (2020-02-12)
+------------------
New
~~~