summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2019-06-19 17:31:13 -0300
committerDanilo J. S. Bellini2019-06-19 17:31:13 -0300
commit965c735beae12762c61604e9ff57c169cafeaa86 (patch)
tree2b07a8ed52f5116b71d55847296ec88dc09217b7
parent42233dfb6fde36ce01109855b4762090b26fc980 (diff)
downloadaur-965c735beae12762c61604e9ff57c169cafeaa86.tar.gz
v1.0.24-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15a1bb7a6c50..c8b696476677 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-rasterio
pkgdesc = Fast and direct raster I/O for use with Numpy and SciPy (Python 2)
- pkgver = 1.0.0
+ pkgver = 1.0.24
pkgrel = 1
url = https://github.com/mapbox/rasterio
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = python2-rasterio
depends = python2-numpy
depends = python2-snuggs
depends = python2-attrs
+ depends = python2-click
depends = python2-click-plugins
depends = python2-enum34
depends = python2-setuptools
@@ -20,8 +21,8 @@ pkgbase = python2-rasterio
optdepends = python2-boto3: AWS S3 raster access
optdepends = python2-matplotlib: plt object (rio insp), rasterio.plot module
options = !emptydirs
- source = https://files.pythonhosted.org/packages/33/22/ad2ea27c9829582ab5280f35cc61e424970ce0add34e258c9e171a62cb73/rasterio-1.0.0.tar.gz
- sha256sums = 6f2e90f2b740d727b36e39550e2a949d52551717812f9b4748f9bc351d666274
+ source = https://files.pythonhosted.org/packages/57/84/be5689470a73f5f8988cf44b81cb3493ebb8abbbebb69768c8fc86fccdd5/rasterio-1.0.24.tar.gz
+ sha256sums = 4839479621045211f66868ec49625979693450bc2e476f23e7e8ac4804eaf452
pkgname = python2-rasterio
diff --git a/PKGBUILD b/PKGBUILD
index 65031ca77b45..ba988eae838c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
_name=rasterio
pkgname=('python2-rasterio')
-pkgver=1.0.0
+pkgver=1.0.24
pkgrel=1
pkgdesc="Fast and direct raster I/O for use with Numpy and SciPy (Python 2)"
arch=('x86_64')
@@ -9,24 +9,24 @@ url="https://github.com/mapbox/rasterio"
license=('BSD')
makedepends=('python2-setuptools' 'cython2')
depends=('python2-affine' 'python2-cligj' 'python2-numpy' 'python2-snuggs'
- 'python2-attrs'
+ 'python2-attrs' 'python2-click'
'python2-click-plugins' 'python2-enum34' 'python2-setuptools' 'gdal')
optdepends=('ipython2: Alternative inspector interpreter (rio insp --ipython)'
'python2-boto3: AWS S3 raster access'
'python2-matplotlib: plt object (rio insp), rasterio.plot module')
options=(!emptydirs)
-sha256sums=('6f2e90f2b740d727b36e39550e2a949d52551717812f9b4748f9bc351d666274')
+sha256sums=('4839479621045211f66868ec49625979693450bc2e476f23e7e8ac4804eaf452')
_pypi='https://files.pythonhosted.org/packages'
-_path='33/22/ad2ea27c9829582ab5280f35cc61e424970ce0add34e258c9e171a62cb73'
+_path='57/84/be5689470a73f5f8988cf44b81cb3493ebb8abbbebb69768c8fc86fccdd5'
source=("$_pypi/$_path/$_name-$pkgver.tar.gz")
build() {
- cd "$srcdir/rasterio-$pkgver"
+ cd "$srcdir/$_name-$pkgver"
python2 setup.py build
}
package() {
- cd "$srcdir/rasterio-$pkgver"
+ cd "$srcdir/$_name-$pkgver"
python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}