summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEthan Kerrick2021-12-10 13:55:58 -0500
committerEthan Kerrick2021-12-10 13:55:58 -0500
commit967c6dcc80728d948e09b0ae3867b0061a94ee15 (patch)
treea6882afb44a8d5c6171d3e2922a617956e92ef6f
parent42e79367835f34de35e399756d46f6d62ca8afde (diff)
downloadaur-967c6dcc80728d948e09b0ae3867b0061a94ee15.tar.gz
change dependencies and add libadwaita fallback
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68c9d89a4b5a..a021b699b5c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = zrythm-git
pkgdesc = a highly automated and intuitive digital audio workstation
- pkgver = 1.0.0.alpha.26.0.13.r0.gf8acad4d9
+ pkgver = 1.0.0.alpha.26.0.13.r77.g7f64601af
pkgrel = 1
epoch = 1
url = https://www.zrythm.org
@@ -20,7 +20,6 @@ pkgbase = zrythm-git
makedepends = lv2
makedepends = gtksourceview3
makedepends = cmake
- depends = gtk3
depends = lilv
depends = libx11
depends = jack
@@ -39,6 +38,9 @@ pkgbase = zrythm-git
depends = xxhash
depends = vamp-plugin-sdk
depends = carla-git
+ depends = gtk4
+ depends = guile
+ depends = graphviz
optdepends = portaudio: portaudio backend
optdepends = qt5-base: for embedding qt5 plugin UIs
provides = zrythm
diff --git a/PKGBUILD b/PKGBUILD
index 58eb1bf8020e..015dc7181574 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
# Contributor: Elijah Gregg <lovetocode999@ctrl-c.club>
# Contributor: Alexandros Theodotou <alex@zrythm.org>
pkgname=zrythm-git
-pkgver=1.0.0.alpha.26.0.13.r0.gf8acad4d9
+pkgver=1.0.0.alpha.26.0.13.r77.g7f64601af
pkgrel=1
epoch=1
pkgdesc='a highly automated and intuitive digital audio workstation'
arch=('x86_64' 'i686')
url="https://www.zrythm.org"
license=('AGPL3')
-depends=('gtk3' 'lilv' 'libx11' 'jack' 'libsndfile' 'libyaml' 'libsamplerate' 'alsa-lib' 'fftw'
+depends=('lilv' 'libx11' 'jack' 'libsndfile' 'libyaml' 'libsamplerate' 'alsa-lib' 'fftw'
'suil' 'breeze-icons' 'lv2' 'rubberband' 'python-sphinx-furo' 'python-sphinx-copybutton' 'python-sphinxcontrib-svg2pdfconverter'
- 'xxhash' 'vamp-plugin-sdk' 'carla-git')
+ 'xxhash' 'vamp-plugin-sdk' 'carla-git' 'gtk4' 'guile' 'graphviz')
makedepends=('ruby-sass' 'python' 'gettext' 'sed' 'python-sphinx-intl'
'meson' 'ninja' 'help2man' 'python-sphinx'
'ladspa' 'lv2' 'gtksourceview3' 'cmake')
@@ -31,14 +31,14 @@ pkgver() {
build() {
cd "$srcdir/${pkgname%-git}"
- meson build --prefix=/usr -Dtests=true -Dmanpage=true -Dcarla=enabled
+ meson build --prefix=/usr -Dmanpage=true -Dcarla=enabled -Dforce_fallback_for=libadwaita
ninja -C build
}
-check() {
- cd "$srcdir/${pkgname%-git}"
- ninja -C build test
-}
+#check() {
+# cd "$srcdir/${pkgname%-git}"
+# ninja -C build test
+#}
package() {
cd "$srcdir/${pkgname%-git}"