summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrej Radovic2022-01-29 01:51:45 +0100
committerAndrej Radovic2022-01-29 01:51:45 +0100
commit96a82926701f4ce2767b57425adb037271a16255 (patch)
tree22ba0c41b92b042d928cf10e95b6c2bdf44ae691
downloadaur-96a82926701f4ce2767b57425adb037271a16255.tar.gz
initial version on AUR
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD35
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..99e38f57a6e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = firefox-history-merger
+ pkgdesc = A CLI application to merge Firefox history and repair missing favicons
+ pkgver = 2.12.0
+ pkgrel = 1
+ url = https://github.com/crazy-max/firefox-history-merger
+ arch = x86_64
+ license = GPL
+ makedepends = go
+ source = https://github.com/crazy-max/firefox-history-merger/archive/refs/tags/2.12.0.tar.gz
+ sha512sums = 9d8ecdd5a8825a047d2fb64580749cc63b8dd09252ff2b17d5af45532a625f0663da7c49bcc911406a63362f94d553521c1ca492407acdc11c30cc615d9d54f3
+
+pkgname = firefox-history-merger
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70dd2368947b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=firefox-history-merger
+pkgver=2.12.0
+pkgrel=1
+pkgdesc='A CLI application to merge Firefox history and repair missing favicons'
+arch=('x86_64')
+url="https://github.com/crazy-max/firefox-history-merger"
+license=('GPL')
+makedepends=('go')
+source=("$url/archive/refs/tags/$pkgver.tar.gz")
+sha512sums=('9d8ecdd5a8825a047d2fb64580749cc63b8dd09252ff2b17d5af45532a625f0663da7c49bcc911406a63362f94d553521c1ca492407acdc11c30cc615d9d54f3')
+
+prepare(){
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build ./...
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ go test ./...
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+}