summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfusion8092016-10-14 11:31:40 +1000
committerfusion8092016-10-14 11:31:40 +1000
commit96b1ac06d780e9eaf4de2f7aa836d432050e0570 (patch)
tree7fb7217474c36bcbe90adc07c4122a1a9c74d733
downloadaur-96b1ac06d780e9eaf4de2f7aa836d432050e0570.tar.gz
Initial commit
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD42
-rw-r--r--fix-mutiny-fresh.patch18
4 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7da97a0b861
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+# Generated by mksrcinfo v8
+# Fri Oct 14 01:31:40 UTC 2016
+pkgbase = mate-tweak-gtk2
+ pkgdesc = Tweak tool for MATE, a fork of MintDesktop - GTK2 version.
+ pkgver = 16.10.4
+ pkgrel = 1
+ url = https://bitbucket.org/ubuntu-mate/mate-tweak
+ arch = any
+ license = GPL
+ makedepends = python-distutils-extra
+ makedepends = python-setuptools
+ depends = gtk2
+ depends = libnotify
+ depends = mate-applets
+ depends = python-configobj
+ depends = python-gobject
+ depends = python-psutil
+ depends = python-setproctitle
+ optdepends = mate-applet-dock: for Mutiny panel layout
+ optdepends = mate-menu: to enable advanced menu
+ optdepends = mate-netbook: for Netbook panel layout
+ optdepends = plank: for Cupertino panel layout
+ optdepends = synapse: to enable launcher
+ optdepends = tilda: to enable pull-down terminal
+ optdepends = topmenu-gtk: for Mutiny panel layout
+ provides = mate-tweak
+ conflicts = mate-tweak
+ source = mate-tweak-16.10.4.tar.gz::https://bitbucket.org/ubuntu-mate/mate-tweak/get/16.10.4.tar.gz
+ source = https://launchpad.net/ubuntu/+archive/primary/+files/ubuntu-mate-settings_16.10.7.tar.xz
+ source = fix-mutiny-fresh.patch
+ sha256sums = 474a4ee963554650f963223430a7e5d7e4d08e8ef00f4a7c76dc4515a2f181fe
+ sha256sums = bf0046befe9b8704e5b9972fc86da3847b0b458b72a186f8ebf5d7b30ee591ac
+ sha256sums = ac2ade84a532486c50245a176d370f0815330f13df07fd62e133afe0383db5fc
+
+pkgname = mate-tweak-gtk2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f21935a8d455
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.xz
+pkg
+src
+*.gz
+*.bz2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0f3cb1bbc32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Brenton Horne <brentonhorne77 at gmail dot com>
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=mate-tweak-gtk2
+_pkgname=${pkgname//-gtk2/}
+pkgver=16.10.4
+_umsver=16.10.7
+pkgrel=1
+pkgdesc="Tweak tool for MATE, a fork of MintDesktop - GTK2 version."
+arch=('any')
+url="https://bitbucket.org/ubuntu-mate/mate-tweak"
+license=('GPL')
+provides=('mate-tweak')
+conflicts=('mate-tweak')
+depends=('gtk2' 'libnotify' 'mate-applets' 'python-configobj' 'python-gobject' 'python-psutil' 'python-setproctitle')
+makedepends=('python-distutils-extra' 'python-setuptools')
+optdepends=('mate-applet-dock: for Mutiny panel layout'
+ 'mate-menu: to enable advanced menu'
+ 'mate-netbook: for Netbook panel layout'
+ 'plank: for Cupertino panel layout'
+ 'synapse: to enable launcher'
+ 'tilda: to enable pull-down terminal'
+ 'topmenu-gtk: for Mutiny panel layout')
+source=("$_pkgname-$pkgver.tar.gz::https://bitbucket.org/ubuntu-mate/${_pkgname}/get/$pkgver.tar.gz"
+ "https://launchpad.net/ubuntu/+archive/primary/+files/ubuntu-mate-settings_$_umsver.tar.xz"
+ "fix-mutiny-fresh.patch")
+sha256sums=('474a4ee963554650f963223430a7e5d7e4d08e8ef00f4a7c76dc4515a2f181fe'
+ 'bf0046befe9b8704e5b9972fc86da3847b0b458b72a186f8ebf5d7b30ee591ac'
+ 'ac2ade84a532486c50245a176d370f0815330f13df07fd62e133afe0383db5fc')
+
+prepare() {
+ cd ubuntu-mate-${_pkgname}-*
+ sed -i 's|/usr/lib/mate-applets/topmenu-mate-panel-applet|/usr/lib/topmenu-gtk/topmenu-mate-panel-applet|' mate-tweak
+ cd ../ubuntu-mate-settings
+ patch -Np1 -i ../fix-mutiny-fresh.patch
+}
+
+package() {
+ cd ubuntu-mate-${_pkgname}-*
+ python3 setup.py install --root="$pkgdir" --optimize=1
+ cp -r "$srcdir"/ubuntu-mate-settings/usr/share/mate-panel "$pkgdir/usr/share"
+}
diff --git a/fix-mutiny-fresh.patch b/fix-mutiny-fresh.patch
new file mode 100644
index 000000000000..ebc0d0a303e3
--- /dev/null
+++ b/fix-mutiny-fresh.patch
@@ -0,0 +1,18 @@
+diff -Naur ubuntu-mate-settings-16.04.1.orig/usr/share/mate-panel/layouts/mutiny-fresh.panel ubuntu-mate-settings-16.04.1/usr/share/mate-panel/layouts/mutiny-fresh.panel
+--- ubuntu-mate-settings-16.04.1.orig/usr/share/mate-panel/layouts/mutiny-fresh.panel 2016-02-21 19:16:14.000000000 +0100
++++ ubuntu-mate-settings-16.04.1/usr/share/mate-panel/layouts/mutiny-fresh.panel 2016-02-26 04:51:48.024833424 +0100
+@@ -16,6 +16,14 @@
+ screen=0
+ size=24
+
++[objects/topmenu]
++applet-iid='TopMenuMatePanelAppletFactory::TopMenuMatePanelApplet'
++locked=true
++toplevel-id='top'
++position=48
++object-type='applet'
++panel-right-stick=false
++
+ [objects/notification-area]
+ applet-iid='NotificationAreaAppletFactory::NotificationArea'
+ locked=true