summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2022-11-15 15:31:13 +0000
committerScore_Under2022-11-15 15:31:13 +0000
commit96b411c9c11d76e7a04c1667477dbd16e029d2c2 (patch)
tree7d228d35832ffaf0090c3c85094438a6f9c8ae92
parent4dd6b18db22c05a89b06263596f8b458b7246446 (diff)
downloadaur-96b411c9c11d76e7a04c1667477dbd16e029d2c2.tar.gz
Update for v1.11.2c and patch makefile bug
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
-rw-r--r--make-clean-fix.patch10
3 files changed, 31 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a6805c45c12..2e91b09657c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bandwidth
pkgdesc = Benchmark memory bandwidth
- pkgver = 1.11.2
+ pkgver = 1.11.2.c
pkgrel = 1
url = http://zsmith.co/bandwidth.php
arch = i686
@@ -9,7 +9,9 @@ pkgbase = bandwidth
makedepends = nasm
options = !makeflags
options = !debug
- source = https://zsmith.co/archives/bandwidth-1.11.2.tar.gz
- sha256sums = 9a3b6f400387f6bbf5d97b3319d0f98485f5f7b7abed473be167d568fdf64e93
+ source = https://zsmith.co/archives/bandwidth-1.11.2c.tar.gz
+ source = make-clean-fix.patch
+ sha256sums = 1f4cc154424c811e66fc9eb96d66a8ed8e874f6900398e666acbda2a1fd562fd
+ sha256sums = 3d997fa73b24608ae47d02849b8fd63e5168327b1be3f2fa6088317282c8d91b
pkgname = bandwidth
diff --git a/PKGBUILD b/PKGBUILD
index 442449619dea..9913c68b02c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,9 @@
+_orig_ver=1.11.2
+_orig_patch=c
+_orig_fullver=$_orig_ver$_orig_patch
+
pkgname=bandwidth
-pkgver=1.11.2
+pkgver=$_orig_ver${_orig_patch:+.$_orig_patch}
pkgrel=1
pkgdesc="Benchmark memory bandwidth"
arch=('i686' 'x86_64')
@@ -7,11 +11,18 @@ url="http://zsmith.co/bandwidth.php"
license=('GPL')
makedepends=('nasm')
options=(!makeflags !debug)
-sha256sums=('9a3b6f400387f6bbf5d97b3319d0f98485f5f7b7abed473be167d568fdf64e93')
-source=("https://zsmith.co/archives/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('1f4cc154424c811e66fc9eb96d66a8ed8e874f6900398e666acbda2a1fd562fd'
+ '3d997fa73b24608ae47d02849b8fd63e5168327b1be3f2fa6088317282c8d91b')
+source=("https://zsmith.co/archives/${pkgname}-${_orig_fullver}.tar.gz"
+ make-clean-fix.patch)
+
+prepare() {
+ cd "${srcdir}"
+ patch -N -p0 -d "${pkgname}-${_orig_fullver}" < ../make-clean-fix.patch
+}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${_orig_fullver}"
make clean
@@ -23,7 +34,7 @@ build() {
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${_orig_fullver}"
if [ "${CARCH}" = "x86_64" ]; then
install -Dm755 bandwidth64 "${pkgdir}"/usr/bin/bandwidth
else
diff --git a/make-clean-fix.patch b/make-clean-fix.patch
new file mode 100644
index 000000000000..969151633111
--- /dev/null
+++ b/make-clean-fix.patch
@@ -0,0 +1,10 @@
+--- OOC/Makefile 2022-11-15 15:25:59.668336806 +0000
++++ OOC/Makefile.fixed 2022-11-15 15:25:53.498212219 +0000
+@@ -31,6 +31,6 @@
+ ar rvs OOC64.a ${OOC_OBJ}
+
+ clean:
+- chmod 644 *.c *.h *.asm *.txt Makefile*
++ -chmod 644 *.c *.h *.asm *.txt Makefile*
+ rm -f ${OOC_OBJ} OOC32.a OOC64.a
+