summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302019-08-22 14:57:30 +0200
committerM0Rf302019-08-22 14:57:30 +0200
commit96ca36558325e88fa363757845c9a7796261b87f (patch)
tree22114c490427832c0b660b3d90ee18aef49d0c6f
parentc0720baa8a84ae91a31fb7a2e81b47c14309d830 (diff)
downloadaur-96ca36558325e88fa363757845c9a7796261b87f.tar.gz
iortcw-data: added openurl.sh
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--openurl.sh8
3 files changed, 17 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d74731b7df3..ed4936869c4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = iortcw-data
pkgdesc = Return to Castle Wolfenstein Single Player pk3s files (shared use)
pkgver = 1.51c
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/iortcw/iortcw
install = iortcw-data.install
arch = any
@@ -13,10 +13,12 @@ pkgbase = iortcw-data
source = https://github.com/M0Rf30/rtcw-assets/raw/master/sp_pak2.pk3
source = https://github.com/M0Rf30/rtcw-assets/raw/master/mp_pak1.pk3
source = https://github.com/M0Rf30/rtcw-assets/raw/master/mp_pak2.pk3
+ source = openurl.sh
md5sums = 291a37caa9d65d0b81f767918b76fa56
md5sums = 330b272d5261fe19fcf3c3fbc943c7f3
md5sums = 22b972974f499a237c96a2200b0d019e
md5sums = 30f29ffa81748a957e0441af8c14cb56
+ md5sums = 11a60b83bcfb4b953344db248d886000
pkgname = iortcw-data
diff --git a/PKGBUILD b/PKGBUILD
index a4343b2638d0..1496f2f7827d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=iortcw-data
pkgver=1.51c
-pkgrel=2
+pkgrel=3
pkgdesc="Return to Castle Wolfenstein Single Player pk3s files (shared use)"
arch=('any')
url="https://github.com/iortcw/iortcw"
@@ -11,7 +11,8 @@ install='iortcw-data.install'
source=("https://github.com/iortcw/iortcw/releases/download/$pkgver/patch-data-141.zip"
"https://github.com/M0Rf30/rtcw-assets/raw/master/sp_pak2.pk3"
"https://github.com/M0Rf30/rtcw-assets/raw/master/mp_pak1.pk3"
-"https://github.com/M0Rf30/rtcw-assets/raw/master/mp_pak2.pk3")
+ "https://github.com/M0Rf30/rtcw-assets/raw/master/mp_pak2.pk3"
+'openurl.sh')
noextract=('sp_pak2.pk3' 'mp_pak1.pk3' 'mp_pak2.pk3')
package() {
@@ -26,10 +27,10 @@ package() {
cp ../sp_pak2.pk3 $pkgdir/opt/iortcw-data/
cp ../mp_pak1.pk3 $pkgdir/opt/iortcw-data/
cp ../mp_pak2.pk3 $pkgdir/opt/iortcw-data/
-
+ install -D -m 755 ../openurl.sh $pkgdir/opt/iortcw-data/
}
-
md5sums=('291a37caa9d65d0b81f767918b76fa56'
'330b272d5261fe19fcf3c3fbc943c7f3'
'22b972974f499a237c96a2200b0d019e'
-'30f29ffa81748a957e0441af8c14cb56')
+ '30f29ffa81748a957e0441af8c14cb56'
+'11a60b83bcfb4b953344db248d886000')
diff --git a/openurl.sh b/openurl.sh
new file mode 100644
index 000000000000..41fd1f42d0e8
--- /dev/null
+++ b/openurl.sh
@@ -0,0 +1,8 @@
+#!/bin/sh
+# use this script to customize the way the engine should open URLs
+
+xdg-open "$1"
+
+# other possibilities .. not exhaustive of course ..
+# opera "$1"
+# xterm -e lynx "$1"