summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authors-ol2019-12-18 10:58:26 +0100
committers-ol2019-12-18 11:13:50 +0100
commit96cdd35137c7b0a962c244a80deedd79262ba151 (patch)
tree99e0ae81ecac4a9d592f19da4992db4ede91c1c2
parentca1393c5f23c12a3a970e7a8b64452891315306a (diff)
downloadaur-96cdd35137c7b0a962c244a80deedd79262ba151.tar.gz
use patchkit patcher
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD56
-rwxr-xr-xgdrive-download.sh9
-rw-r--r--velocidrone.desktop5
4 files changed, 46 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ca8a5647ba3..b17f2fdf7f5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,20 @@
pkgbase = velocidrone
- pkgdesc = Velocidrone: Fast paced FPV drone racing action with multiplayer and offline modes!
- pkgver = 1.11.0.418
+ pkgdesc = a fast paced multi-player and single player FPV drone racing simulator
+ pkgver = 1
pkgrel = 1
- url = http://www.velocidrone.com/
+ url = https://www.velocidrone.com/
arch = x86_64
license = proprietary
- makedepends = wget
- makedepends = unzip
- depends = gcc-libs
- depends = gtk2
- optdepends = steam
- noextract = velocidrone-1.11.0.418.zip
- source = velocidrone-1.11.0.418.zip::gdrive://1-1GUMzEQVWmhunqapUMmZOH9I2fZCukM
+ makedepends = qt5-base
+ makedepends = boost
+ source = git+https://github.com/patchkit-net/patchkit-launcher-qt.git
+ source = debian_launcher.zip::local://Velocidrone%20Debian%20Launcher.zip
+ source = velocidrone.png::https://www.velocidrone.com/img/logo.png
source = velocidrone.desktop
- source = https://www.velocidrone.com/img/logo.png
- sha256sums = 4bed1615377317279bafc61f6ba57fa37f0ae969a37c62724f70c5814f94ffff
- sha256sums = 66ab24798d6b40f2c69f42368b79205f1e39ace4d8880785bfeb47f7f20d98cb
- sha256sums = dca386606781e552fc310bf414a911b335bb8d48114091f337d02db46befdee1
+ md5sums = SKIP
+ md5sums = 556d05b0af4bace44167549bec0e7542
+ md5sums = e176f8bb5bded2510b7368fcb7c99ce6
+ md5sums = 85bc86aef45aa4be289fac68506330de
pkgname = velocidrone
diff --git a/PKGBUILD b/PKGBUILD
index 074d6d5dedfa..912da2624d49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,39 @@
-# Maintainer: Frans-Willem Hardijzer <fw@hardijzer.nl>
+# Maintainer: Sol Bekic <s+aur at s-ol dot nu>
-pkgname=velocidrone
-pkgver=1.11.0.418
+pkgname="velocidrone"
+pkgver=1
pkgrel=1
-pkgdesc="Velocidrone: Fast paced FPV drone racing action with multiplayer and offline modes!"
+pkgdesc="a fast paced multi-player and single player FPV drone racing simulator"
+url="https://www.velocidrone.com/"
arch=('x86_64')
-url="http://www.velocidrone.com/"
license=('proprietary')
-makedepends=(wget unzip)
-depends=(gcc-libs gtk2)
-optdepends=(steam)
-conflicts=()
-_source_id=""
-DLAGENTS+=('gdrive::./gdrive-download.sh %u %o')
-source=(
- "velocidrone-$pkgver.zip::gdrive://1-1GUMzEQVWmhunqapUMmZOH9I2fZCukM"
- "velocidrone.desktop"
- "https://www.velocidrone.com/img/logo.png")
-noextract=("velocidrone-$pkgver.zip")
-sha256sums=('4bed1615377317279bafc61f6ba57fa37f0ae969a37c62724f70c5814f94ffff'
- '66ab24798d6b40f2c69f42368b79205f1e39ace4d8880785bfeb47f7f20d98cb'
- 'dca386606781e552fc310bf414a911b335bb8d48114091f337d02db46befdee1')
+makedepends=('qt5-base' 'boost')
+depends=()
+
+OPTIONS=(!strip)
+
+source=("git+https://github.com/patchkit-net/patchkit-launcher-qt.git"
+ "debian_launcher.zip::local://Velocidrone%20Debian%20Launcher.zip"
+ "velocidrone.png::https://www.velocidrone.com/img/logo.png"
+ "velocidrone.desktop")
+md5sums=('SKIP'
+ '556d05b0af4bace44167549bec0e7542'
+ 'e176f8bb5bded2510b7368fcb7c99ce6'
+ '85bc86aef45aa4be289fac68506330de')
+
+build() {
+ cd patchkit-launcher-qt
+ export PK_LAUNCHER_BOOST_LIBDIR=/usr/lib
+ qmake # CONFIG+=debug
+ make
+}
package() {
- mkdir -p "$pkgdir/opt/velocidrone/"
- unzip "$srcdir/velocidrone-$pkgver.zip" -d "$pkgdir/opt/velocidrone/"
- chmod ugo+x "$pkgdir/opt/velocidrone/velocidrone.x86_64"
- install -Dm644 "$srcdir/velocidrone.desktop" "${pkgdir}/usr/share/applications/$pkgname.desktop"
- install -Dm 644 "$srcdir/logo.png" "${pkgdir}/opt/velocidrone/icon.png"
+ install -Dm755 patchkit-launcher-qt/app/Launcher "$pkgdir"/usr/share/velocidrone/Launcher
+ install -Dm644 launcher.dat "$pkgdir"/usr/share/velocidrone/launcher.dat
+ install -Dm644 velocidrone.png "$pkgdir"/usr/share/icons/hicolor/48x48/apps/velocidrone.png
+ install -Dm644 velocidrone.desktop "$pkgdir"/usr/share/applications/velocidrone.desktop
+
+ mkdir -p "$pkgdir"/usr/bin
+ ln -s /usr/share/velocidrone/Launcher "$pkgdir"/usr/bin/velocidrone
}
diff --git a/gdrive-download.sh b/gdrive-download.sh
deleted file mode 100755
index 6a5d359d017e..000000000000
--- a/gdrive-download.sh
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/bash
-TMPDIR=$(mktemp -d)
-GDRIVE_ID=${1:9}
-echo "Downloading GDrive ID $GDRIVE_ID"
-echo "TMPDIR: $TMPDIR"
-wget -c "https://drive.google.com/uc?export=download&id=$GDRIVE_ID" -O "$TMPDIR/avcheck.html" --save-cookie "$TMPDIR/cookie.txt"
-CONFIRM=$(grep -e "confirm=[^'\"&]\+" -o "$TMPDIR/avcheck.html")
-wget "https://drive.google.com/uc?export=download&id=$GDRIVE_ID&$CONFIRM" -O $2 --load-cookie "$TMPDIR/cookie.txt" --continue
-rm -rf $TMPDIR
diff --git a/velocidrone.desktop b/velocidrone.desktop
index e194e9622c56..a2ce751c2a06 100644
--- a/velocidrone.desktop
+++ b/velocidrone.desktop
@@ -1,8 +1,7 @@
[Desktop Entry]
-Version=1.11.0.299
Name=Velocidrone
-Exec=/opt/velocidrone/velocidrone.x86_64
-Icon=/opt/velocidrone/icon.png
+Exec=/usr/bin/velocidrone
+Icon=velocidrone.png
Terminal=false
Type=Application
Categories=Game;