summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-05-07 00:59:19 -0700
committerxiota2023-05-07 00:59:19 -0700
commit96dc5bbf12105cb7d34a1996bfedfebc7f358d18 (patch)
tree8a8ef8ae5dc9371a7813086eff2b115dad8f2071
parent6002b29440a1702577dae22e8a15129f33ca2454 (diff)
downloadaur-96dc5bbf12105cb7d34a1996bfedfebc7f358d18.tar.gz
switch to maintained fork
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD75
3 files changed, 63 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f895dc34b57..dda62b35d3ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Sun Sep 1 15:15:20 UTC 2019
pkgbase = qlog-git
pkgdesc = Amateur radio logbook software
- pkgver = r40.b01ae89
+ pkgver = r1197.08f9652
pkgrel = 1
- url = https://github.com/7h0ma5/QLog
+ url = https://github.com/foldynl/QLog
arch = x86_64
arch = i686
license = GPL
@@ -12,14 +10,15 @@ pkgbase = qlog-git
makedepends = qt5-tools
depends = qt5-base
depends = qt5-charts
- depends = postgresql-libs
+ depends = qt5-webengine
+ depends = qtkeychain-qt5
+ depends = qt5-serialport
depends = hamlib
- provides = qlog-git
- conflicts = qlog-git
- source = git://github.com/7h0ma5/QLog
- source = git://github.com/7h0ma5/QLog-Flags
- md5sums = SKIP
- md5sums = SKIP
+ provides = qlog
+ conflicts = qlog
+ source = qlog::git+https://github.com/foldynl/QLog
+ source = flags::git+https://github.com/foldynl/QLog-Flags
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = qlog-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 88c6f5215c2e..009ef21a8d41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,64 @@
-# Maintainer: Thomas Gatzweiler <thomas.gatzweiler@gmail.com>
-pkgname=qlog-git # '-bzr', '-git', '-hg' or '-svn'
-pkgver=r40.b01ae89
+# Contributor: Thomas Gatzweiler <thomas.gatzweiler@gmail.com>
+
+_pkgname=qlog
+pkgname="$_pkgname-git"
+pkgver=r1197.08f9652
pkgrel=1
pkgdesc="Amateur radio logbook software"
arch=("x86_64" "i686")
-url="https://github.com/7h0ma5/QLog"
+url="https://github.com/foldynl/QLog"
license=('GPL')
-groups=()
-depends=('qt5-base' 'qt5-charts' 'postgresql-libs' 'hamlib')
-makedepends=('git' 'qt5-tools')
-provides=("${pkgname%-VCS}")
-conflicts=("${pkgname%-VCS}")
-replaces=()
-backup=()
-options=()
-install=
-source=('git://github.com/7h0ma5/QLog' 'git://github.com/7h0ma5/QLog-Flags')
-noextract=()
-md5sums=('SKIP' 'SKIP')
+depends=(
+ 'qt5-base'
+ 'qt5-charts'
+ 'qt5-webengine'
+ 'qtkeychain-qt5'
+ 'qt5-serialport'
+ 'hamlib'
+)
+makedepends=(
+ 'git'
+ 'qt5-tools'
+)
+provides=("$_pkgname")
+conflicts=(${provides[@]})
+source=(
+ "$_pkgname"::"git+$url"
+
+ # submodule
+ "flags"::"git+https://github.com/foldynl/QLog-Flags"
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+)
pkgver() {
- cd "$srcdir/QLog"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "$srcdir/QLog"
- git submodule init
- git config submodule.res/flags.url $srcdir/QLog-Flags
- git submodule update
+ # prepare submodules
+ cd "$srcdir/$_pkgname"
+ _submodules=(
+ 'res/flags'
+ )
+ for submodule in ${_submodules[@]} ; do
+ mkdir -p "$submodule"
+ git submodule init ${submodule}
+ git submodule set-url ${submodule} "${srcdir}/${submodule##*/}"
+ git -c protocol.file.allow=always submodule update ${submodule}
+ done
}
build() {
- cd "$srcdir/QLog"
- qmake PREFIX=${pkgdir}/usr QLog.pro
- make || return 1
+ cd "$srcdir/$_pkgname"
+ qmake PREFIX="$pkgdir/usr" QLog.pro
+ make
}
package() {
- cd "$srcdir/QLog"
- make install || return 1
+ cd "$srcdir/$_pkgname"
+ make install
}