summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorent Thiéry2015-12-09 23:16:40 +0100
committerFlorent Thiéry2015-12-09 23:16:40 +0100
commit96e8c649e62ef266318f7b93868ca2f71eeac062 (patch)
tree65a919cf9d5fe7b9ea137c670f8a42ae7620fe06
downloadaur-96e8c649e62ef266318f7b93868ca2f71eeac062.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2f3009f8a01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gst-gtklaunch-1.0
+ pkgdesc = A utility for testing and controlling live GStreamer 1.0 pipelines. It will inspect the specified pipeline to create the GTK GUI automagically using introspection
+ pkgver = 2015.12.9
+ pkgrel = 1
+ url = https://github.com/UbiCastTeam/gst-gtklaunch-1.0
+ arch = any
+ license = LGPL
+ makedepends = git
+ depends = python
+ depends = python-gobject
+ depends = gtk3
+ depends = xdot
+ depends = graphviz
+ source = git+https://github.com/UbiCastTeam/gst-gtklaunch-1.0.git
+ sha512sums = SKIP
+
+pkgname = gst-gtklaunch-1.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d15a60b6a5a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Florent Thiéry <fthiery@gmail.com>
+pkgname="gst-gtklaunch-1.0"
+pkgver=2015.12.9
+pkgrel=1
+pkgdesc="A utility for testing and controlling live GStreamer 1.0 pipelines. It
+will inspect the specified pipeline to create the GTK GUI automagically using
+introspection"
+arch=('any')
+license=('LGPL')
+url="https://github.com/UbiCastTeam/${pkgname}"
+depends=('python' 'python-gobject' 'gtk3' 'xdot' 'graphviz')
+source=("git+${url}.git")
+sha512sums=('SKIP')
+makedepends=('git')
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: