summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDiab Neiroukh2021-01-24 14:17:51 +0000
committerDiab Neiroukh2021-01-24 14:17:51 +0000
commit96ea2ef131065328dee8f2488679a71aa951b5d7 (patch)
tree1beb0ff7f16d922197fee6211feb3661e2ef2803
parent08c0e4902573e745dac05c0f9e2436226a639c95 (diff)
downloadaur-96ea2ef131065328dee8f2488679a71aa951b5d7.tar.gz
🐛 FIX:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD41
2 files changed, 28 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe6403a71efe..881af63bd70b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
pkgbase = llvm-proton-bin
pkgdesc = A LLVM and Clang compiler toolchain built for kernel development
- pkgver = 20200425
+ pkgver = 20210123
pkgrel = 1
epoch = 1
url = https://github.com/kdrag0n/proton-clang
arch = x86_64
license = custom
options = !strip
- source = https://github.com/kdrag0n/proton-clang/archive/20200425.tar.gz
- b2sums = 170b04de633379e20f9c9b600016d7e743c74e7d4154078e306b60e9d4559892581bb9ff86f7cbef7f42ca32ed92be698cce7f103a05dfac8148ddf7e9c5f27a
+ source = https://github.com/kdrag0n/proton-clang/archive/20210123.tar.gz
+ source = license-llvm.txt::https://raw.githubusercontent.com/llvm/llvm-project/4a1b95bda0c444798a5240fe924dd127b776d12d/llvm/LICENSE.TXT
+ source = license-binutils.txt::https://www.gnu.org/licenses/gpl-3.0.txt
+ b2sums = SKIP
+ b2sums = 74efe5f21dd0f11cf12ba23a94f7e1f3032512e9e10f2d35cc3dc9cfc67277112d152af1e05363b56280cd7437f41f093200a5aef7b7e52f9f3325c9be9d20ca
+ b2sums = 74915e048cf8b5207abf603136e7d5fcf5b8ad512cce78a2ebe3c88fc3150155893bf9824e6ed6a86414bbe4511a6bd4a42e8ec643c63353dc8eea4a44a021cd
pkgname = llvm-proton-bin
diff --git a/PKGBUILD b/PKGBUILD
index e88dc668e30b..dbd88f648f4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,31 @@
# Maintainer: Diab Neiroukh <officiallazerl0rd@gmail.com>
+# Contributor: Albert I (krasCGQ) <kras@raphielgang.org>
pkgname="llvm-proton-bin"
-pkgver=20200425
+pkgver=20210123
pkgrel=1
epoch=1
-arch=(
- "x86_64"
-)
pkgdesc="A LLVM and Clang compiler toolchain built for kernel development"
+arch=(x86_64)
url="https://github.com/kdrag0n/proton-clang"
-license=(
- "custom"
-)
-options=(
- "!strip"
-)
-source=(
- "https://github.com/kdrag0n/proton-clang/archive/$pkgver.tar.gz"
-)
-b2sums=(
- "170b04de633379e20f9c9b600016d7e743c74e7d4154078e306b60e9d4559892581bb9ff86f7cbef7f42ca32ed92be698cce7f103a05dfac8148ddf7e9c5f27a"
-)
+license=(custom)
+options=(!strip)
+source=(https://github.com/kdrag0n/proton-clang/archive/$pkgver.tar.gz
+ license-llvm.txt::https://raw.githubusercontent.com/llvm/llvm-project/4a1b95bda0c444798a5240fe924dd127b776d12d/llvm/LICENSE.TXT
+ license-binutils.txt::https://www.gnu.org/licenses/gpl-3.0.txt)
+b2sums=('SKIP'
+ '74efe5f21dd0f11cf12ba23a94f7e1f3032512e9e10f2d35cc3dc9cfc67277112d152af1e05363b56280cd7437f41f093200a5aef7b7e52f9f3325c9be9d20ca'
+ '74915e048cf8b5207abf603136e7d5fcf5b8ad512cce78a2ebe3c88fc3150155893bf9824e6ed6a86414bbe4511a6bd4a42e8ec643c63353dc8eea4a44a021cd')
-package()
-{
- install -d "$pkgdir/opt"
+pkgver() {
+ ( set -o pipefail
+ curl -s "https://api.github.com/repos/$(echo $url | sed 's/https\?:\/\/github.com\///')/releases/latest" |
+ grep -w tag_name | cut -d ':' -f 2 | sed -e 's/[[:space:]]//' -e 's/"//g' -e 's/,//'
+ )
+}
- cp -r "proton-clang-$pkgver" "$pkgdir/opt/proton-clang"
+package() {
+ install -d "$pkgdir/opt"
+ cp -r "proton-clang-$pkgver" "$pkgdir/opt/proton-clang"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" license-{llvm,binutils}.txt
}