summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2024-04-20 11:58:53 +0200
committerHans-Nikolai Viessmann2024-04-20 11:58:53 +0200
commit970bfb1e9645c00612ee1febf21f6eb92df0dbd2 (patch)
treefbca9cd131a089e3cf0ecb0d7a4c9a57d1be8599
parent02f03e846883f597388d93367e6aa41cf117ed20 (diff)
downloadaur-970bfb1e9645c00612ee1febf21f6eb92df0dbd2.tar.gz
ensure we compile against ffmpeg4.4
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b00bd4f52194..05a84362f059 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = moc-pulse-svn
pkgdesc = An ncurses console audio player with support for pulseaudio (SVN)
pkgver = r3005
- pkgrel = 1
+ pkgrel = 2
url = http://moc.daper.net
arch = i686
arch = x86_64
license = GPL
makedepends = speex
- makedepends = ffmpeg
+ makedepends = ffmpeg4.4
makedepends = taglib
makedepends = libmpcdec
makedepends = wavpack
@@ -21,9 +21,10 @@ pkgbase = moc-pulse-svn
depends = curl
depends = libltdl
depends = file
+ depends = sndio
depends = pulseaudio
optdepends = speex: for using the speex plugin
- optdepends = ffmpeg: for using the ffmpeg plugin
+ optdepends = ffmpeg4.4: for using the ffmpeg plugin
optdepends = taglib: for using the musepack plugin
optdepends = libmpcdec: for using the musepack plugin
optdepends = wavpack: for using the wavpack plugin
diff --git a/PKGBUILD b/PKGBUILD
index 68abfb762b68..cc2fe4d535ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,16 @@
_pkgname=moc
pkgname="${_pkgname}-pulse-svn"
pkgver=r3005
-pkgrel=1
+pkgrel=2
pkgdesc='An ncurses console audio player with support for pulseaudio (SVN)'
url='http://moc.daper.net'
arch=('i686' 'x86_64')
license=('GPL')
-depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file' 'pulseaudio')
-makedepends=('speex' 'ffmpeg' 'taglib' 'libmpcdec' 'wavpack'
+depends=('libmad' 'libid3tag' 'jack' 'curl' 'libltdl' 'file' 'sndio' 'pulseaudio')
+makedepends=('speex' 'ffmpeg4.4' 'taglib' 'libmpcdec' 'wavpack'
'libmodplug' 'subversion' 'faad2' 'pulseaudio')
optdepends=('speex: for using the speex plugin'
- 'ffmpeg: for using the ffmpeg plugin'
+ 'ffmpeg4.4: for using the ffmpeg plugin'
'taglib: for using the musepack plugin'
'libmpcdec: for using the musepack plugin'
'wavpack: for using the wavpack plugin'
@@ -45,11 +45,14 @@ prepare() {
patch -p1 -i ../0001-Pulseaudio-backend.patch
# re-configure
- autoreconf -f -i -Wall,no-obsolete
+ autoreconf -i -f
}
build() {
cd "$srcdir/$pkgname"
+
+ export PKG_CONFIG_PATH='/usr/lib/ffmpeg4.4/pkgconfig'
+
./configure --prefix=/usr --without-rcc --with-pulse \
--with-alsa --with-oss --with-jack --with-aac --with-mp3 \
--with-musepack --with-vorbis --with-flac --with-wavpack \
@@ -62,3 +65,5 @@ package() {
cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir" install
}
+
+# vim: ts=2 sw=2