summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrobot Viktor2019-05-03 13:00:27 +0300
committerDrobot Viktor2019-05-03 13:00:27 +0300
commit970e73b6e2c0f931be28f38cacd5f8952ff4964a (patch)
treef4f437e5de7fa9b47b8a8ce47267e56bb7e84f30
parent51c68cd5f190de7bf644d1fd1c2537309d8bee8d (diff)
downloadaur-970e73b6e2c0f931be28f38cacd5f8952ff4964a.tar.gz
Update
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD58
2 files changed, 36 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cbf38482321..e7d3de0650fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
-pkgbase = libint2
- pkgdesc = A high-performance library for evaluation of molecular integrals of many-body operators over Gaussian functions
- pkgver = 2.3.0
- pkgrel = 2
+pkgbase = libint
+ pkgdesc = A library for the evaluation of molecular integrals of many-body operators over Gaussian functions
+ pkgver = 2.5.0
+ pkgrel = 1
url = https://github.com/evaleev/libint
- arch = i686
arch = x86_64
- license = GPL
- makedepends = gcc
- makedepends = automake
+ license = GPL3
+ makedepends = make
makedepends = autoconf
+ makedepends = doxygen
+ makedepends = clang
+ makedepends = texlive-bin
depends = boost
depends = boost-libs
- source = https://github.com/evaleev/libint/archive/master.zip
- md5sums = SKIP
+ depends = gmp
+ options = !strip
+ source = https://github.com/evaleev/libint/archive/v2.5.0.tar.gz
+ sha1sums = ab49e3c3691bbeb32310d81f0bfff315db4213f2
-pkgname = libint2
+pkgname = libint
diff --git a/PKGBUILD b/PKGBUILD
index 778d6d28c1b9..1ab78454ec49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,32 @@
-# Maintainer: Alexander Oleynichenko <alexvoleynichenko@gmail.com>
-pkgname=libint2
-pkgver='2.3.0'
-pkgrel=2
-epoch=
-pkgdesc="A high-performance library for evaluation of molecular integrals of many-body operators over Gaussian functions"
-arch=('i686' 'x86_64')
-url="https://github.com/evaleev/libint"
-license=('GPL')
-groups=()
-depends=(boost boost-libs)
-makedepends=(gcc automake autoconf)
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("https://github.com/evaleev/libint/archive/master.zip")
-noextract=()
-md5sums=('SKIP')
-validpgpkeys=()
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+pkgname=libint
+pkgver=2.5.0
+pkgrel=1
+pkgdesc='A library for the evaluation of molecular integrals of many-body operators over Gaussian functions'
+url='https://github.com/evaleev/libint'
+license=('GPL3')
+arch=('x86_64')
+depends=('boost' 'boost-libs' 'gmp')
+makedepends=('make' 'autoconf' 'doxygen' 'clang' 'texlive-bin')
+source=("https://github.com/evaleev/libint/archive/v${pkgver}.tar.gz")
+sha1sums=('ab49e3c3691bbeb32310d81f0bfff315db4213f2')
+options=(!strip)
build() {
- cd "$srcdir/libint-master"
+ cd ${srcdir}/${pkgname}-${pkgver}
+
./autogen.sh
+
mkdir build
cd build
- ../configure --prefix=/usr
- make -j8
-}
-check() {
- cd "$srcdir/libint-master/build"
-# You may uncomment 'make check' line if you want;
-# however, check is a VERY time-consuming and actually not needed
-# make -k check
+ ../configure --prefix=/usr
+ make
}
package() {
- cd "$srcdir/libint-master/build"
- make DESTDIR="$pkgdir/" install
+ cd ${srcdir}/${pkgname}-${pkgver}/build
+
+ make DESTDIR="$pkgdir" install
}