summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2022-05-07 19:35:45 +0300
committerCaleb Maclennan2022-05-07 19:35:45 +0300
commit971ac2963ac7b1460236aea717e883205325f98f (patch)
tree154e793355d3779418339476e2c444dee55c829d
parent1e3a0fc20f6b925ee09adb81386f48cd5a07174c (diff)
downloadaur-971ac2963ac7b1460236aea717e883205325f98f.tar.gz
upgpkg: teal 0.13.2-4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 16 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35e67166009f..52db2a8e16ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = teal
pkgdesc = The compiler for Teal, a typed dialect of Lua
pkgver = 0.13.2
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/teal-language/tl
arch = any
license = MIT
@@ -20,21 +20,9 @@ pkgname = teal
provides = tl
pkgname = lua-tl
- depends = lua
- depends = lua-argparse
- depends = lua-filesystem
pkgname = lua53-tl
- depends = lua53
- depends = lua53-argparse
- depends = lua53-filesystem
pkgname = lua52-tl
- depends = lua52
- depends = lua52-argparse
- depends = lua52-filesystem
pkgname = lua51-tl
- depends = lua51
- depends = lua51-argparse
- depends = lua51-filesystem
diff --git a/PKGBUILD b/PKGBUILD
index 94e0356acea5..27fd038574b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@ _rockname=tl
pkgbase=teal
pkgname=(teal "lua-$_rockname" "lua53-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
pkgver=0.13.2
-pkgrel=3
-pkgdesc="The compiler for Teal, a typed dialect of Lua"
+pkgrel=4
+pkgdesc='The compiler for Teal, a typed dialect of Lua'
arch=(any)
url=https://github.com/teal-language/$_rockname
license=(MIT)
-_lua_deps=(argparse
- filesystem)
+_luadeps=(argparse
+ filesystem)
makedepends=(lua
lua51
lua52
@@ -19,10 +19,11 @@ makedepends=(lua
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
sha256sums=('a42c8dd1719933de027f8954b3edd4b255785d933f6ff183ae32bbf8adc7c6ae')
-_package_helper() {
+_package() {
cd "$_rockname-$pkgver"
- luarocks --lua-version=$1 --tree="$pkgdir/usr/" \
- make --deps-mode=none --no-manifest "$_rockname-dev-1.rockspec"
+ depends=("${pkgname%-*}" "${_luadeps[@]/#/${pkgname%-*}-}")
+ luarocks --lua-version $1 --tree "$pkgdir/usr/" \
+ make --deps-mode none --no-manifest -- "$_rockname-dev-1.rockspec"
find "$pkgdir/usr/bin" -type f -execdir sed -i -e "s#$pkgdir##" {} \;
[[ -v 2 ]] &&
rm -rf "$pkgdir/usr/"{lib,share} ||
@@ -33,27 +34,23 @@ package_teal() {
depends+=(lua lua-tl)
optdepends+=('cyan: The Teal build system and project manager')
provides+=($_rockname)
- _package_helper 5.4 bin
+ _package 5.4 bin
}
package_lua-tl() {
- depends+=(lua "${_lua_deps[@]/#/lua-}")
- _package_helper 5.4
+ _package 5.4
}
package_lua53-tl() {
- depends+=(lua53 "${_lua_deps[@]/#/lua53-}")
- _package_helper 5.3
+ _package 5.3
}
package_lua52-tl() {
- _lua_deps+=(compat53)
- depends+=(lua52 "${_lua_deps[@]/#/lua52-}")
- _package_helper 5.2
+ _luadeps+=(compat53)
+ _package 5.2
}
package_lua51-tl() {
- _lua_deps+=(compat53)
- depends+=(lua51 "${_lua_deps[@]/#/lua51-}")
- _package_helper 5.1
+ _luadeps+=(compat53)
+ _package 5.1
}