summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 22:15:46 +0800
committerSukanka2022-06-06 22:15:46 +0800
commit971e7d8eb0dfedb4708e4934902ece753917c423 (patch)
treea9c47f3182e00a9e6c7580cbf4ff70e40da13942
downloadaur-971e7d8eb0dfedb4708e4934902ece753917c423.tar.gz
add r-scgps
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD63
2 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7498822c496
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+pkgbase = r-scgps
+ pkgdesc = A complete analysis of single cell subpopulations, from identifying subpopulations to analysing their relationship (scGPS = single cell Global Predictions of Subpopulation)
+ pkgver = 1.10.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/scGPS
+ arch = x86_64
+ license = GPL
+ depends = r
+ depends = r-caret
+ depends = r-deseq2
+ depends = r-dplyr
+ depends = r-dynamictreecut
+ depends = r-fastcluster
+ depends = r-ggplot2
+ depends = r-glmnet
+ depends = r-locfit
+ depends = r-rcpp
+ depends = r-rcpparmadillo
+ depends = r-rcppparallel
+ depends = r-singlecellexperiment
+ depends = r-summarizedexperiment
+ depends = make
+ optdepends = r-biocparallel
+ optdepends = r-clusterprofiler
+ optdepends = r-cowplot
+ optdepends = r-dendextend
+ optdepends = r-devtools
+ optdepends = r-dose
+ optdepends = r-e1071
+ optdepends = r-knitr
+ optdepends = r-matrix
+ optdepends = r-networkd3
+ optdepends = r-org.hs.eg.db
+ optdepends = r-parallel
+ optdepends = r-rcolorbrewer
+ optdepends = r-reactomepa
+ optdepends = r-reshape2
+ optdepends = r-rmarkdown
+ optdepends = r-rtsne
+ optdepends = r-testthat
+ optdepends = r-wgcna
+ optdepends = r-xlsx
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/scGPS_1.10.0.tar.gz
+ sha256sums = 7f537f1ce15b67dcb9a8eabeb60f36c655158c087d036a8900f4452ffaf1b57c
+
+pkgname = r-scgps
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d657d71f9a49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# system requirements: GNU make
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=scGPS
+_pkgver=1.10.0
+pkgname=r-${_pkgname,,}
+pkgver=1.10.0
+pkgrel=1
+pkgdesc='A complete analysis of single cell subpopulations, from identifying subpopulations to analysing their relationship (scGPS = single cell Global Predictions of Subpopulation)'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-caret
+ r-deseq2
+ r-dplyr
+ r-dynamictreecut
+ r-fastcluster
+ r-ggplot2
+ r-glmnet
+ r-locfit
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppparallel
+ r-singlecellexperiment
+ r-summarizedexperiment
+ make
+)
+optdepends=(
+ r-biocparallel
+ r-clusterprofiler
+ r-cowplot
+ r-dendextend
+ r-devtools
+ r-dose
+ r-e1071
+ r-knitr
+ r-matrix
+ r-networkd3
+ r-org.hs.eg.db
+ r-parallel
+ r-rcolorbrewer
+ r-reactomepa
+ r-reshape2
+ r-rmarkdown
+ r-rtsne
+ r-testthat
+ r-wgcna
+ r-xlsx
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('7f537f1ce15b67dcb9a8eabeb60f36c655158c087d036a8900f4452ffaf1b57c')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: