summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Bernardoff2015-06-27 09:52:08 +0200
committerVincent Bernardoff2015-06-27 09:52:08 +0200
commit973b1efffdeedb75d0826ddc3a9db6a6df5cd7fb (patch)
treea84b2c72a90b4d0766eab6d5946f3d1f1a0eb871
downloadaur-973b1efffdeedb75d0826ddc3a9db6a6df5cd7fb.tar.gz
Initial import
-rw-r--r--.AURINFO20
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
3 files changed, 78 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..65fd5345b26a
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,20 @@
+pkgbase = zbar-git
+ pkgdesc = Application and library for reading bar codes from various sources
+ pkgver = iPhoneSDK.1.3.1.r10.g453a338
+ pkgrel = 1
+ url = http://zbar.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = LGPL
+ depends = v4l-utils
+ depends = autoconf
+ conflicts = zbar-gtk
+ conflicts = zbar-qt
+ conflicts = zbar
+ source = zbar-git::git://github.com/vbmithr/ZBar#branch=neon
+ md5sums = SKIP
+
+pkgname = zbar-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65fd5345b26a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = zbar-git
+ pkgdesc = Application and library for reading bar codes from various sources
+ pkgver = iPhoneSDK.1.3.1.r10.g453a338
+ pkgrel = 1
+ url = http://zbar.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = LGPL
+ depends = v4l-utils
+ depends = autoconf
+ conflicts = zbar-gtk
+ conflicts = zbar-qt
+ conflicts = zbar
+ source = zbar-git::git://github.com/vbmithr/ZBar#branch=neon
+ md5sums = SKIP
+
+pkgname = zbar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa0db2bba1c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Marti Raudsepp <marti@juffo.org>
+# Contributor: Radu Andries <admiral0@tuxfamily.org>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
+# Contributor: Vincent Bernardoff <vb@luminar.eu.org>
+
+pkgname=zbar-git
+pkgver=iPhoneSDK.1.3.1.r10.g453a338
+pkgrel=1
+pkgdesc="Application and library for reading bar codes from various sources"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="http://zbar.sourceforge.net/"
+license=('LGPL')
+depends=('v4l-utils' 'autoconf')
+conflicts=('zbar-gtk' 'zbar-qt' 'zbar')
+source=("$pkgname"::'git://github.com/vbmithr/ZBar#branch=neon')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+
+ autoreconf --install
+ ./configure --prefix=/usr --without-python --without-qt --without-gtk
+
+ make
+}
+
+package() {
+ cd "$pkgname"
+
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: