summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjmcb2022-09-09 16:33:10 +0100
committerjmcb2022-09-09 16:33:10 +0100
commit977fa6ccaa98dd65ba85d609299890a5b82c4dbe (patch)
tree7aaf5b6076532f9e4e452f8d7fe877bd44adcbf4
parent8a8f6ee1fd8d3b3d3fe377dc8530078b93f3d2a9 (diff)
downloadaur-977fa6ccaa98dd65ba85d609299890a5b82c4dbe.tar.gz
Trim and enhance
-rw-r--r--.gitignore1
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD10
-rw-r--r--bro_idle.pngbin3761 -> 0 bytes
-rw-r--r--bro_transparent.pngbin1188 -> 0 bytes
-rwxr-xr-xbuild.sh4
6 files changed, 5 insertions, 34 deletions
diff --git a/.gitignore b/.gitignore
index f06a8dd34d3e..8895c7cca508 100644
--- a/.gitignore
+++ b/.gitignore
@@ -10,6 +10,5 @@
*.sig
*.atr
-aur/
pkg/
src/
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index fdddb29aa445..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,24 +0,0 @@
-This is free and unencumbered software released into the public domain.
-
-Anyone is free to copy, modify, publish, use, compile, sell, or
-distribute this software, either in source code form or as a compiled
-binary, for any purpose, commercial or non-commercial, and by any
-means.
-
-In jurisdictions that recognize copyright laws, the author or authors
-of this software dedicate any and all copyright interest in the
-software to the public domain. We make this dedication for the benefit
-of the public at large and to the detriment of our heirs and
-successors. We intend this dedication to be an overt act of
-relinquishment in perpetuity of all present and future rights to this
-software under copyright law.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
-IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
-OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
-ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
-OTHER DEALINGS IN THE SOFTWARE.
-
-For more information, please refer to <https://unlicense.org>
diff --git a/PKGBUILD b/PKGBUILD
index 03d6d8b340ef..734c37e11799 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: jmcb <joelsgp@protonmail.com>
pkgname=bros
pkgver=1.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Atari 800XL platformer"
arch=('any')
url="http://www.atarimania.com/game-atari-400-800-xl-xe-tobot-bros_5425.html"
@@ -10,9 +10,9 @@ depends=('altirra')
source=('https://archive.org/download/a8b_Bros_1989_KE_Soft_DE_en_a3/Bros_1989_KE_Soft_DE_en_a3.atr'
"${pkgname}.desktop"
"${pkgname}.png")
-md5sums=('6f9164dc8e7710a08b11e747e80962c0'
- '23b04e32efa794095fe00b9ca75eea35'
- '0b7f361cb8652f6e7259c1dad5035b57')
+sha256sums=('bb659633247cf99b90a8948ce499047503ebb76c31578f181b165ebc3b212009'
+ '8af9e6ece4de8eaa8e06d176f266c46171402f4300ad25c2ab63b6521c0ff3ee'
+ '89c7fbb7a5a2861df064c6010e13ac13d1f42157b5b9e3fee17a8732ff0f6da4')
package() {
# game rom atr
@@ -21,5 +21,5 @@ package() {
# desktop entry
share="${pkgdir}"/usr/share
install -Dm644 ${pkgname}.desktop "${share}"/applications/${pkgname}.desktop
- install -Dm644 ${pkgname}.png "${share}"/icons/${pkgname}.png
+ install -Dm644 ${pkgname}.png "${share}"/pixmaps/${pkgname}.png
}
diff --git a/bro_idle.png b/bro_idle.png
deleted file mode 100644
index 1bfbe591a494..000000000000
--- a/bro_idle.png
+++ /dev/null
Binary files differ
diff --git a/bro_transparent.png b/bro_transparent.png
deleted file mode 100644
index b2516ce3f0cb..000000000000
--- a/bro_transparent.png
+++ /dev/null
Binary files differ
diff --git a/build.sh b/build.sh
deleted file mode 100755
index ba07ee10c141..000000000000
--- a/build.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/bash
-md5sum bros.desktop bros.png
-makepkg -f & \
-makepkg --printsrcinfo > .SRCINFO