summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2017-03-14 16:28:06 +0000
committerGrey Christoforo2017-03-14 16:36:04 +0000
commit9789d9f0bf985ab8bfbb0859917876773b2ee742 (patch)
tree221c66c349bef90a5b7e9261cecf8cdd4d09be63
downloadaur-9789d9f0bf985ab8bfbb0859917876773b2ee742.tar.gz
initial commit
fix name
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD25
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..badc6961c96c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Tue Mar 14 16:29:30 UTC 2017
+pkgbase = python2-pathos-3fix
+ pkgdesc = parallel graph management and execution in heterogeneous computing fixed package - fixed deps
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = http://www.cacr.caltech.edu/~mmckerns/pathos.htm
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-dill
+ depends = python2-pox
+ depends = python2-ppft-fix
+ depends = python2-multiprocess-fix
+ optdepends = python2-pyina
+ optdepends = python2-rpyc
+ provides = python2-pythos
+ conflicts = python2-pathos
+ source = https://files.pythonhosted.org/packages/source/p/pathos/pathos-0.2.0.tgz
+ md5sums = 3e75bd626c4c16a60aa78d9f35de6cfb
+
+pkgname = python2-pathos-3fix
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6fd264a84d0d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.tgz
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba43771e3363
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=('python2-pathos-3fix')
+_module='pathos'
+pkgver='0.2.0'
+pkgrel=1
+pkgdesc="parallel graph management and execution in heterogeneous computing fixed package - fixed deps"
+url="http://www.cacr.caltech.edu/~mmckerns/pathos.htm"
+depends=('python2' 'python2-dill' 'python2-pox' 'python2-ppft-fix' 'python2-multiprocess-fix')
+optdepends=('python2-pyina' 'python2-rpyc')
+provides=('python2-pythos')
+conflicts=('python2-pathos')
+makedepends=('python2-setuptools')
+license=('BSD')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/p/pathos/pathos-${pkgver}.tgz")
+md5sums=('3e75bd626c4c16a60aa78d9f35de6cfb')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}