summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Vreeland2020-03-17 22:27:08 +0000
committerJustin Vreeland2020-03-17 22:40:40 +0000
commit9798d5e5de12bc3b37aca548ac95f23ecd7b5a9b (patch)
treef2c7e8c41b4c9dfbf26e1fe1e2219eae77295df9
parenteacdcdfbc0729a757c58b724de76b632305886a6 (diff)
downloadaur-9798d5e5de12bc3b37aca548ac95f23ecd7b5a9b.tar.gz
3.3-2 fix missing patch and .SRCINFO changes
-rw-r--r--.SRCINFO5
-rw-r--r--0001-Dont-install-thirdparty-libs.patch26
-rw-r--r--PKGBUILD4
3 files changed, 31 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26f2b612cf1a..8b99be0811b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,15 +6,16 @@ pkgbase = sam-ba
arch = x86_64
license = GPL2
makedepends = qt5-tools
+ makedepends = clang
depends = qt5-base
depends = qt5-serialport
depends = qt5-declarative
- source = https://github.com/atmelcorp/sam-ba/archive/v3.3.tar.gz
+ source = sam-ba-3.3.tar.gz::https://github.com/atmelcorp/sam-ba/archive/v3.3.tar.gz
source = 0001-Dont-install-thirdparty-libs.patch
source = 0002-Dont-rely-on-applicationDirPath.patch
source = 0003-Use-newer-qt-version.patch
md5sums = 480f70a38b783df1e599ccc7bf2090ef
- md5sums = 6b29a65bbc96b608d7628e8a25ae1f50
+ md5sums = d41d8cd98f00b204e9800998ecf8427e
md5sums = 1fd871ae02809fcbc3095c169f59ce01
md5sums = 93241311e7ce90508b0af8e91fb61559
diff --git a/0001-Dont-install-thirdparty-libs.patch b/0001-Dont-install-thirdparty-libs.patch
index e69de29bb2d1..ba3580bc5e37 100644
--- a/0001-Dont-install-thirdparty-libs.patch
+++ b/0001-Dont-install-thirdparty-libs.patch
@@ -0,0 +1,26 @@
+diff --git a/dist/dist.pro b/dist/dist.pro
+index ac481c9..2d2baac 100644
+--- a/dist/dist.pro
++++ b/dist/dist.pro
+@@ -32,18 +32,18 @@ unix:{
+ $$[QT_INSTALL_LIBS]/libQt5Qml.so.5 \
+ $$[QT_INSTALL_LIBS]/libQt5Quick.so.5 \
+ $$[QT_INSTALL_LIBS]/libQt5SerialPort.so.5
+- INSTALLS += qtlibs
++ # INSTALLS += qtlibs
+
+ otherlibs.path = /lib
+ otherlibs.files = \
+ $$[QT_INSTALL_LIBS]/libicudata.so.$$ICU_VERSION \
+ $$[QT_INSTALL_LIBS]/libicui18n.so.$$ICU_VERSION \
+ $$[QT_INSTALL_LIBS]/libicuuc.so.$$ICU_VERSION
+- INSTALLS += otherlibs
++ # INSTALLS += otherlibs
+
+ qmlmodules.path = /qml
+ qmlmodules.files = $$[QT_INSTALL_QML]/QtQuick.2
+- INSTALLS += qmlmodules
++ # INSTALLS += qmlmodules
+ }
+ else:win32:{
+ qtlibs.path = /
diff --git a/PKGBUILD b/PKGBUILD
index bf0b5274d11c..98448bcf2ecc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Streetwalrus <streetwalrus@codewalr.us>
pkgname=sam-ba
pkgver=3.3
-pkgrel=1
+pkgrel=2
pkgdesc="Atmel SAM Boot Assistant"
arch=('x86_64')
url="https://github.com/atmelcorp/sam-ba"
@@ -15,7 +15,7 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/atmelcorp/sam-ba/archive/v$
"0003-Use-newer-qt-version.patch"
)
md5sums=('480f70a38b783df1e599ccc7bf2090ef'
- 'd41d8cd98f00b204e9800998ecf8427e'
+ '7115eaa32335e755fe4b17277a15ca7e'
'1fd871ae02809fcbc3095c169f59ce01'
'93241311e7ce90508b0af8e91fb61559')