summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLili12282023-03-29 21:52:48 +0200
committerLili12282023-03-29 21:52:48 +0200
commit97a30ddada2ba5340c5eccc595b4f685bb86f701 (patch)
treec3262d70f8656ee6ccb98e632395f347c53c257b
parent287ca1891a6ea4eabe1b16b1dfd8a1531b76ad03 (diff)
downloadaur-97a30ddada2ba5340c5eccc595b4f685bb86f701.tar.gz
Sync with Arch repo
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD120
-rw-r--r--ply-utils.c.patch28
-rw-r--r--plymouth-update-initrd.patch9
-rw-r--r--plymouth.encrypt_hook140
-rw-r--r--plymouth.encrypt_install47
-rw-r--r--plymouth.install6
-rw-r--r--runstatedir.patch46
8 files changed, 70 insertions, 368 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8566af93bee..3a1d669b5fee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,39 +1,35 @@
pkgbase = plymouth-nosystemd
- pkgdesc = A graphical boot splash screen with kernel mode-setting support for non-systemd setups
+ pkgdesc = Graphical boot splash screen for non-systemd setups
pkgver = 22.02.122
- pkgrel = 4
- url = http://www.freedesktop.org/wiki/Software/Plymouth
+ pkgrel = 7
+ url = https://www.freedesktop.org/wiki/Software/Plymouth/
+ install = plymouth.install
arch = i686
arch = x86_64
- license = GPL
+ license = GPL2
+ makedepends = gtk3
makedepends = docbook-xsl
+ depends = bash
+ depends = cairo
+ depends = cantarell-fonts
+ depends = filesystem
+ depends = glib2
+ depends = glibc
depends = libdrm
+ depends = libpng
depends = pango
depends = elogind
- optdepends = cantarell-fonts: For text output, e.g. during decryption
- optdepends = xf86-video-fbdev: Support special graphic cards on early startup
+ optdepends = gtk3: x11 renderer
provides = plymouth
conflicts = plymouth
backup = etc/plymouth/plymouthd.conf
- source = https://gitlab.freedesktop.org/plymouth/plymouth/-/archive/22.02.122/plymouth-22.02.122.tar.gz
- source = artix-logo.png
- source = plymouth.encrypt_hook
- source = plymouth.encrypt_install
+ source = https://www.freedesktop.org/software/plymouth/releases/plymouth-22.02.122.tar.xz
source = plymouth.initcpio_hook
source = plymouth.initcpio_install
- source = plymouth-update-initrd.patch
- source = plymouthd.conf.patch
- source = ply-utils.c.patch
- source = runstatedir.patch
- sha256sums = 8921cd61a9f32f5f8903ceffb9ab0defaef8326253e1549ef85587c19b7f2ab6
+ source = artix-logo.png
+ sha256sums = 100551442221033ce868c447ad6c74d831d209c18ae232b98ae0207e34eadaeb
+ sha256sums = de852646e615e06d4125eb2e646d0528d1e349bd9e9877c08c5d32c43d288b6f
+ sha256sums = ed2730171d537486986792090874084d78500e702fd355b8b8fed030baddacc4
sha256sums = 2a218ad4f7c202f0164eeccf02263b88b6c93c21301f346270e8bdd40463132c
- sha256sums = 748e0cfa0e10ab781bc202fceeed46e765ed788784f1b85945187b0f29eafad7
- sha256sums = 373ec20fe4c47e693a0c45cc06dd906e35dd1d70a85546bd1d571391de11763a
- sha256sums = 2a80e2cad8de428358647677afa166219589d3338c5f94838146c804a29e2769
- sha256sums = 619be4d3e85457bbec42071bf6c38fb885acdb66ac635e29efad9b5d09c7fa6d
- sha256sums = 74908ba59cea53c6a9ab67bb6dec1de1616f3851a0fd89bb3c157a1c54e6633a
- sha256sums = 71d34351b4313da01e1ceeb082d9776599974ce143c87e93f0a465f342a74fd2
- sha256sums = 1bd7693d1e135fe9e22a03f7635309e2ae616e952665d9774eb5ca4d82718e1b
- sha256sums = 7c0224737119f949b8d5ca24c438f253b5734e3391a47e8f5f1dda28b8c4ab92
pkgname = plymouth-nosystemd
diff --git a/PKGBUILD b/PKGBUILD
index 0126f37d21d8..e024520defda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: oscareczek <at gmail dot com>
+# Maintainer: Lili1228 <aur at gramywpsl dot pl>
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
# Contributor: TankMissile <alecfeldman@disroot.org>
# Contributor: Chris Cromer <chris@cromer.cl>
# Contributor: Sebastian Lau <lauseb644@gmail.com>
@@ -6,95 +7,64 @@
# Contributor: Padfoot <padfoot@exemail.com.au>
_pkgname=plymouth
-pkgname=${_pkgname}-nosystemd
+pkgname="${_pkgname}-nosystemd"
pkgver=22.02.122
-pkgrel=4
-pkgdesc="A graphical boot splash screen with kernel mode-setting support for non-systemd setups"
-url="http://www.freedesktop.org/wiki/Software/Plymouth"
+pkgrel=7
+pkgdesc='Graphical boot splash screen for non-systemd setups'
arch=('i686' 'x86_64')
-license=('GPL')
-
-depends=('libdrm' 'pango' 'elogind')
-makedepends=('docbook-xsl')
-optdepends=('cantarell-fonts: For text output, e.g. during decryption'
- 'xf86-video-fbdev: Support special graphic cards on early startup')
+url='https://www.freedesktop.org/wiki/Software/Plymouth/'
+license=('GPL2')
+depends=('bash' 'cairo' 'cantarell-fonts' 'filesystem' 'glib2' 'glibc' 'libdrm' 'libpng' 'pango' 'elogind')
+makedepends=('gtk3' 'docbook-xsl')
+optdepends=('gtk3: x11 renderer')
provides=('plymouth')
conflicts=('plymouth')
backup=('etc/plymouth/plymouthd.conf')
-
-source=("https://gitlab.freedesktop.org/${_pkgname}/${_pkgname}/-/archive/${pkgver}/${_pkgname}-${pkgver}.tar.gz"
- 'artix-logo.png'
- 'plymouth.encrypt_hook'
- 'plymouth.encrypt_install'
- 'plymouth.initcpio_hook'
- 'plymouth.initcpio_install'
- 'plymouth-update-initrd.patch'
- 'plymouthd.conf.patch'
- 'ply-utils.c.patch'
- 'runstatedir.patch'
-)
-
-sha256sums=('8921cd61a9f32f5f8903ceffb9ab0defaef8326253e1549ef85587c19b7f2ab6'
- '2a218ad4f7c202f0164eeccf02263b88b6c93c21301f346270e8bdd40463132c'
- '748e0cfa0e10ab781bc202fceeed46e765ed788784f1b85945187b0f29eafad7'
- '373ec20fe4c47e693a0c45cc06dd906e35dd1d70a85546bd1d571391de11763a'
- '2a80e2cad8de428358647677afa166219589d3338c5f94838146c804a29e2769'
- '619be4d3e85457bbec42071bf6c38fb885acdb66ac635e29efad9b5d09c7fa6d'
- '74908ba59cea53c6a9ab67bb6dec1de1616f3851a0fd89bb3c157a1c54e6633a'
- '71d34351b4313da01e1ceeb082d9776599974ce143c87e93f0a465f342a74fd2'
- '1bd7693d1e135fe9e22a03f7635309e2ae616e952665d9774eb5ca4d82718e1b'
- '7c0224737119f949b8d5ca24c438f253b5734e3391a47e8f5f1dda28b8c4ab92')
+install='plymouth.install'
+source=("https://www.freedesktop.org/software/${_pkgname}/releases/${_pkgname}-$pkgver.tar.xz"
+ 'plymouth.initcpio_hook'
+ 'plymouth.initcpio_install'
+ 'artix-logo.png')
+sha256sums=('100551442221033ce868c447ad6c74d831d209c18ae232b98ae0207e34eadaeb'
+ 'de852646e615e06d4125eb2e646d0528d1e349bd9e9877c08c5d32c43d288b6f'
+ 'ed2730171d537486986792090874084d78500e702fd355b8b8fed030baddacc4'
+ '2a218ad4f7c202f0164eeccf02263b88b6c93c21301f346270e8bdd40463132c')
prepare() {
- cd "$srcdir"/${_pkgname}-${pkgver}
- patch -p1 -i $srcdir/plymouth-update-initrd.patch
+ cd "${_pkgname}-$pkgver"
+
# systemd
- # patch -p1 -i $srcdir/plymouth-quit.service.in.patch
- patch -p1 -i $srcdir/plymouthd.conf.patch
- # apply upstream patches
- patch -p1 -i $srcdir/ply-utils.c.patch
- patch -p1 -i $srcdir/runstatedir.patch
-}
+ # Add mkinitcpio support to plymouth-switch-root-initramfs.service
+ # https://gitlab.freedesktop.org/plymouth/plymouth/-/merge_requests/202
+ # patch -Np1 -i ../plymouth-shutdown.patch
-build() {
- cd "$srcdir"/${_pkgname}-${pkgver}
+ # Use mkinitcpio to update initrd
+ sed -i 's/dracut -f/mkinitcpio -P/' scripts/plymouth-update-initrd
- LDFLAGS="$LDFLAGS -ludev" ./autogen.sh \
- --prefix=/usr \
- --exec-prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --sbindir=/usr/bin \
- --disable-systemd-integration \
- --enable-drm \
- --enable-tracing \
- --enable-pango \
- --enable-gtk=no \
- --with-release-file=/etc/os-release \
- --with-logo=/usr/share/plymouth/artix-logo.png \
- --with-background-color=0x000000 \
- --with-background-start-color-stop=0x000000 \
- --with-background-end-color-stop=0x4D4D4D \
- --without-rhgb-compat-link \
- --without-system-root-install \
- --runstatedir=/run
+ # Change default theme
+ sed -i 's/^Theme=spinner$/Theme=bgrt/' src/plymouthd.defaults
+}
+build() {
+ cd "${_pkgname}-$pkgver"
+ ./configure --prefix=/usr --sbindir=/usr/bin --libexecdir=/usr/lib --sysconfdir=/etc \
+ --localstatedir=/var --runstatedir=/run --with-runtimedir=/run \
+ --with-logo=/usr/share/plymouth/artix-logo.png --enable-systemd-integration=no
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
package() {
- cd "$srcdir"/${_pkgname}-${pkgver}
-
+ cd "${_pkgname}-$pkgver"
make DESTDIR="$pkgdir" install
+ rm -r "$pkgdir/var/run"
- install -Dm644 "$srcdir/artix-logo.png" "$pkgdir/usr/share/plymouth/artix-logo.png"
-
- install -Dm644 "$srcdir/plymouth.encrypt_hook" "$pkgdir/usr/lib/initcpio/hooks/plymouth-encrypt"
- install -Dm644 "$srcdir/plymouth.encrypt_install" "$pkgdir/usr/lib/initcpio/install/plymouth-encrypt"
- install -Dm644 "$srcdir/plymouth.initcpio_hook" "$pkgdir/usr/lib/initcpio/hooks/plymouth"
- install -Dm644 "$srcdir/plymouth.initcpio_install" "$pkgdir/usr/lib/initcpio/install/plymouth"
-
- install -Dm644 "$pkgdir/usr/share/plymouth/plymouthd.defaults" "$pkgdir/etc/plymouth/plymouthd.conf"
+ # Install mkinitcpio hook
+ install -Dm644 ../plymouth.initcpio_hook "$pkgdir/usr/lib/initcpio/hooks/${_pkgname}"
+ install -Dm644 ../plymouth.initcpio_install "$pkgdir/usr/lib/initcpio/install/${_pkgname}"
+
+ # Install logo for the spinner theme
+ install -Dm644 ../artix-logo.png "$pkgdir/usr/share/${_pkgname}/themes/spinner/watermark.png"
+ install -Dm644 ../artix-logo.png "$pkgdir/usr/share/${_pkgname}/artix-logo.png"
}
+
diff --git a/ply-utils.c.patch b/ply-utils.c.patch
deleted file mode 100644
index 77aeadf31ba4..000000000000
--- a/ply-utils.c.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-@@ -0,0 +1,30 @@
-From 5f1e43c00039a7fe1fff768b91a05a695fb4a53d Mon Sep 17 00:00:00 2001
-From: Ray Strode <rstrode@redhat.com>
-Date: Wed, 3 Aug 2022 15:23:33 -0400
-Subject: [PATCH] ply-utils: Drop linux/fs.h include
-
-It was needed long ago for a function we no longer even have.
-
-Now it's causing compile errors on Fedora 37 because it's conflicting
-with sys/mount.h.
-
-This commit drops it.
----
- src/libply/ply-utils.c | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/src/libply/ply-utils.c b/src/libply/ply-utils.c
-index c7b165e9..219e2e77 100644
---- a/src/libply/ply-utils.c
-+++ b/src/libply/ply-utils.c
-@@ -46,7 +46,6 @@
- #include <sys/user.h>
- #include <sys/wait.h>
- #include <time.h>
--#include <linux/fs.h>
- #include <linux/vt.h>
-
- #include <dlfcn.h>
diff --git a/plymouth-update-initrd.patch b/plymouth-update-initrd.patch
deleted file mode 100644
index 0d0235cf750d..000000000000
--- a/plymouth-update-initrd.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff -aur plymouth.src/scripts/plymouth-update-initrd plymouth.patch/scripts/plymouth-update-initrd
---- plymouth.src/scripts/plymouth-update-initrd 2014-02-20 19:38:13.319427393 +1100
-+++ plymouth.patch/scripts/plymouth-update-initrd 2014-02-20 19:54:13.035553244 +1100
-@@ -1,2 +1,4 @@
- #!/bin/bash
--dracut -f
-+find /etc/mkinitcpio.d/ -name \*.preset -a \! -name example.preset | while read p; do
-+ mkinitcpio -p $p
-+done
diff --git a/plymouth.encrypt_hook b/plymouth.encrypt_hook
deleted file mode 100644
index 8acb9af138e3..000000000000
--- a/plymouth.encrypt_hook
+++ /dev/null
@@ -1,140 +0,0 @@
-#!/bin/bash
-
-run_hook() {
- modprobe -a -q dm-crypt >/dev/null 2>&1
- [ "${quiet}" = "y" ] && CSQUIET=">/dev/null"
-
- # Get keyfile if specified
- ckeyfile="/crypto_keyfile.bin"
- if [ -n "$cryptkey" ]; then
- IFS=: read ckdev ckarg1 ckarg2 <<EOF
-$cryptkey
-EOF
-
- if [ "$ckdev" = "rootfs" ]; then
- ckeyfile=$ckarg1
- elif resolved=$(resolve_device "${ckdev}" ${rootdelay}); then
- case ${ckarg1} in
- *[!0-9]*)
- # Use a file on the device
- # ckarg1 is not numeric: ckarg1=filesystem, ckarg2=path
- mkdir /ckey
- mount -r -t "$ckarg1" "$resolved" /ckey
- dd if="/ckey/$ckarg2" of="$ckeyfile" >/dev/null 2>&1
- umount /ckey
- ;;
- *)
- # Read raw data from the block device
- # ckarg1 is numeric: ckarg1=offset, ckarg2=length
- dd if="$resolved" of="$ckeyfile" bs=1 skip="$ckarg1" count="$ckarg2" >/dev/null 2>&1
- ;;
- esac
- fi
- [ ! -f ${ckeyfile} ] && echo "Keyfile could not be opened. Reverting to passphrase."
- fi
-
- if [ -n "${cryptdevice}" ]; then
- DEPRECATED_CRYPT=0
- IFS=: read cryptdev cryptname cryptoptions <<EOF
-$cryptdevice
-EOF
- else
- DEPRECATED_CRYPT=1
- cryptdev="${root}"
- cryptname="root"
- fi
-
- warn_deprecated() {
- echo "The syntax 'root=${root}' where '${root}' is an encrypted volume is deprecated"
- echo "Use 'cryptdevice=${root}:root root=/dev/mapper/root' instead."
- }
-
- for cryptopt in ${cryptoptions//,/ }; do
- case ${cryptopt} in
- allow-discards|discard)
- cryptargs="${cryptargs} --allow-discards"
- ;;
- no-read-workqueue|perf-no_read_workqueue)
- cryptargs="${cryptargs} --perf-no_read_workqueue"
- ;;
- no-write-workqueue|perf-no_write_workqueue)
- cryptargs="${cryptargs} --perf-no_write_workqueue"
- ;;
- *)
- echo "Encryption option '${cryptopt}' not known, ignoring." >&2
- ;;
- esac
- done
-
- if resolved=$(resolve_device "${cryptdev}" ${rootdelay}); then
- if cryptsetup isLuks ${resolved} >/dev/null 2>&1; then
- [ ${DEPRECATED_CRYPT} -eq 1 ] && warn_deprecated
- dopassphrase=1
- # If keyfile exists, try to use that
- if [ -f ${ckeyfile} ]; then
- if eval cryptsetup --key-file ${ckeyfile} luksOpen ${resolved} ${cryptname} ${cryptargs} ${CSQUIET}; then
- dopassphrase=0
- else
- echo "Invalid keyfile. Reverting to passphrase."
- fi
- fi
- # Ask for a passphrase
- if [ ${dopassphrase} -gt 0 ]; then
- echo
- echo "A password is required to access the ${cryptname} volume:"
- plymouth ask-for-password --prompt="Password for ${cryptname} volume" --dont-pause-progress --number-of-tries=5 --command="/sbin/cryptsetup luksOpen --key-file=- ${resolved} ${cryptname} ${cryptargs} ${CSQUIET}"
- sleep 2
- fi
- if [ -e "/dev/mapper/${cryptname}" ]; then
- if [ ${DEPRECATED_CRYPT} -eq 1 ]; then
- export root="/dev/mapper/root"
- fi
- else
- err "Password succeeded, but ${cryptname} creation failed, aborting..."
- exit 1
- fi
- elif [ -n "${crypto}" ]; then
- [ ${DEPRECATED_CRYPT} -eq 1 ] && warn_deprecated
- msg "Non-LUKS encrypted device found..."
- if echo "$crypto" | awk -F: '{ exit(NF == 5) }'; then
- err "Verify parameter format: crypto=hash:cipher:keysize:offset:skip"
- err "Non-LUKS decryption not attempted..."
- return 1
- fi
- exe="cryptsetup create $cryptname $resolved $cryptargs"
- IFS=: read c_hash c_cipher c_keysize c_offset c_skip <<EOF
-$crypto
-EOF
- [ -n "$c_hash" ] && exe="$exe --hash '$c_hash'"
- [ -n "$c_cipher" ] && exe="$exe --cipher '$c_cipher'"
- [ -n "$c_keysize" ] && exe="$exe --key-size '$c_keysize'"
- [ -n "$c_offset" ] && exe="$exe --offset '$c_offset'"
- [ -n "$c_skip" ] && exe="$exe --skip '$c_skip'"
- if [ -f "$ckeyfile" ]; then
- exe="$exe --key-file $ckeyfile"
- else
- exe="$exe --verify-passphrase"
- echo ""
- echo "A password is required to access the ${cryptname} volume:"
- fi
- eval "$exe $CSQUIET"
-
- if [ $? -ne 0 ]; then
- err "Non-LUKS device decryption failed. verify format: "
- err " crypto=hash:cipher:keysize:offset:skip"
- exit 1
- fi
- if [ -e "/dev/mapper/${cryptname}" ]; then
- if [ ${DEPRECATED_CRYPT} -eq 1 ]; then
- export root="/dev/mapper/root"
- fi
- else
- err "Password succeeded, but ${cryptname} creation failed, aborting..."
- exit 1
- fi
- else
- err "Failed to open encryption mapping: The device ${cryptdev} is not a LUKS volume and the crypto= paramater was not specified."
- fi
- fi
- rm -f ${ckeyfile}
-}
diff --git a/plymouth.encrypt_install b/plymouth.encrypt_install
deleted file mode 100644
index 5088e7dc1886..000000000000
--- a/plymouth.encrypt_install
+++ /dev/null
@@ -1,47 +0,0 @@
-#!/bin/bash
-
-build() {
- local mod
-
- add_module dm-crypt
- if [[ $CRYPTO_MODULES ]]; then
- for mod in $CRYPTO_MODULES; do
- add_module "$mod"
- done
- else
- add_all_modules '/crypto/'
- fi
-
- add_binary "cryptsetup"
- add_binary "dmsetup"
- add_file "/usr/lib/udev/rules.d/10-dm.rules"
- add_file "/usr/lib/udev/rules.d/13-dm-disk.rules"
- add_file "/usr/lib/udev/rules.d/95-dm-notify.rules"
- add_file "/usr/lib/initcpio/udev/11-dm-initramfs.rules" "/usr/lib/udev/rules.d/11-dm-initramfs.rules"
-
- # cryptsetup calls pthread_create(), which dlopen()s libgcc_s.so.1
- add_binary "/usr/lib/libgcc_s.so.1"
-
- add_runscript
-}
-
-help() {
- cat <<HELPEOF
-This hook allows for an encrypted root device. Users should specify the device
-to be unlocked using 'cryptdevice=device:dmname' on the kernel command line,
-where 'device' is the path to the raw device, and 'dmname' is the name given to
-the device after unlocking, and will be available as /dev/mapper/dmname.
-
-For unlocking via keyfile, 'cryptkey=device:fstype:path' should be specified on
-the kernel cmdline, where 'device' represents the raw block device where the key
-exists, 'fstype' is the filesystem type of 'device' (or auto), and 'path' is
-the absolute path of the keyfile within the device.
-
-Without specifying a keyfile, you will be prompted for the password at runtime.
-This means you must have a keyboard available to input it, and you may need
-the keymap hook as well to ensure that the keyboard is using the layout you
-expect.
-HELPEOF
-}
-
-# vim: set ft=sh ts=4 sw=4 et:
diff --git a/plymouth.install b/plymouth.install
new file mode 100644
index 000000000000..9e6858eb0643
--- /dev/null
+++ b/plymouth.install
@@ -0,0 +1,6 @@
+post_upgrade() {
+ # Show warning for users of the old package from AUR
+ if (( $(vercmp $2 '22.02.122-5') < 0 )); then
+ echo "WARNING: The 'plymouth-encrypt' hook no longer exists in the package. You should replace ithem with 'encrypt' hook in your 'mkinitcpio.conf'."
+ fi
+}
diff --git a/runstatedir.patch b/runstatedir.patch
deleted file mode 100644
index 963b6e910e07..000000000000
--- a/runstatedir.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 608ad02c8b268f1ffa6e0ba62dea7da2eaed0636..34a2f2ce68abe648f79ccbf93505f1ccf8c4d744 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -140,9 +140,7 @@ if test x$enable_systemd_integration = xyes; then
- AC_SUBST(SYSTEMD_UNIT_DIR)
- fi
-
--AC_ARG_WITH([runtimedir],
-- AC_HELP_STRING([--with-runtimedir=DIR], [runtime data dir [LOCALSTATEDIR/run]]),
-- [plymouthruntimedir=${withval}/plymouth], [plymouthruntimedir=""])
-+AC_ARG_WITH([runtimedir], [], [AC_MSG_ERROR([--with-runtimedir is obsolete, use --runstatedir instead])], [])
-
- AC_ARG_WITH(system-root-install, AS_HELP_STRING([--with-system-root-install],[Install client in /bin and daemon in /sbin]),with_system_root_install=${withval},with_system_root_install=no)
- AM_CONDITIONAL(WITH_SYSTEM_ROOT_INSTALL, [test "$with_system_root_install" = yes])
-@@ -150,16 +148,11 @@ AM_CONDITIONAL(WITH_SYSTEM_ROOT_INSTALL, [test "$with_system_root_install" = ye
- if test x$with_system_root_install = xyes; then
- plymouthclientdir=/bin
- plymouthdaemondir=/sbin
-- if (test -z "${plymouthruntimedir}"); then
-- plymouthruntimedir=/run/plymouth
-- fi
- else
- plymouthclientdir=$bindir
- plymouthdaemondir=$sbindir
-- if (test -z "${plymouthruntimedir}"); then
-- plymouthruntimedir=$localstatedir/run/plymouth
-- fi
- fi
-+plymouthruntimedir=$runstatedir/plymouth
- AC_SUBST(plymouthclientdir)
- AC_SUBST(plymouthdaemondir)
- AC_SUBST(plymouthruntimedir)
-diff --git a/src/Makefile.am b/src/Makefile.am
-index ad3655d5944cebad36761cee44d9d79241a6d942..abd7a4ce2aafa21b73303b9cc6d3639c58706a90 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -37,7 +37,7 @@ escrow_PROGRAMS = plymouthd-fd-escrow
-
- plymouthd_fd_escrow_SOURCES = plymouthd-fd-escrow.c
-
--plymouthdrundir = $(localstatedir)/run/plymouth
-+plymouthdrundir = $(plymouthruntimedir)
- plymouthdspooldir = $(localstatedir)/spool/plymouth
- plymouthdtimedir = $(localstatedir)/lib/plymouth
-