summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBastian Löher2015-07-20 16:17:08 +0200
committerBastian Löher2015-07-20 16:17:08 +0200
commit97dd0a53001bc5bbbe3f7e68bf0f8b12384a30cc (patch)
tree209ba6d8341c9db51af8697d2ba825fd30180c85
downloadaur-97dd0a53001bc5bbbe3f7e68bf0f8b12384a30cc.tar.gz
Initial commit moving to AUR4.
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD68
-rw-r--r--fairroot.install16
3 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8e5be95fe6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = fairroot
+ pkgdesc = Analysis framework based on root provided by GSI/FAIR.
+ pkgver = 15.07
+ pkgrel = 1
+ url = http://fairroot.gsi.de
+ install = fairroot.install
+ arch = x86_64
+ license = LGPL3
+ makedepends = cmake
+ makedepends = clang
+ makedepends = bison
+ makedepends = flex
+ makedepends = gcc-fortran
+ makedepends = subversion
+ makedepends = git
+ makedepends = curl
+ depends = fairsoft
+ options = !emptydirs
+ options = staticlibs
+ options = libtool
+ options = !strip
+ source = https://github.com/FairRootGroup/FairRoot/archive/v-15.07.tar.gz
+ source = fairroot.install
+ md5sums = 3c5f73693b00844e8cb0d91ec7b1aba3
+ md5sums = d2d2d7b11b308120382fba7e32c5268a
+
+pkgname = fairroot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44edf5fb67a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Bastian Löher <b.loeher@gsi.de>
+pkgname=fairroot
+pkgver=15.07
+fairsoftver=jul15-1
+pkgrel=1
+pkgdesc="Analysis framework based on root provided by GSI/FAIR."
+arch=('x86_64')
+url="http://fairroot.gsi.de"
+license=('LGPL3')
+groups=()
+makedepends=('cmake'
+ 'clang'
+ 'bison'
+ 'flex'
+ 'gcc-fortran'
+ 'subversion'
+ 'git'
+ 'curl')
+depends=(
+ 'fairsoft'
+ )
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=('!emptydirs' 'staticlibs' 'libtool' '!strip')
+install=fairroot.install
+changelog=
+source=("https://github.com/FairRootGroup/FairRoot/archive/v-${pkgver}.tar.gz"
+ 'fairroot.install'
+ )
+noextract=()
+md5sums=('3c5f73693b00844e8cb0d91ec7b1aba3'
+ 'd2d2d7b11b308120382fba7e32c5268a')
+
+# Do not compress the package for installation
+# PKGEXT='.pkg.tar'
+# Compress using lightweight gzip
+PKGEXT='.pkg.tar.gz'
+
+prepare() {
+ # Path to fairsoft installation
+ export SIMPATH=/opt/fairsoft/${fairsoftver}
+
+ cd ${srcdir}/FairRoot-v-${pkgver}
+
+ # Execute cmake
+ cd ${srcdir}
+ [ -d build ] || mkdir build
+ cd build
+ cmake \
+ -DUSE_DIFFERENT_COMPILER=TRUE \
+ -DCMAKE_INSTALL_PREFIX="/opt/fairroot/v-${pkgver}" \
+ ../FairRoot-v-${pkgver}
+:
+}
+
+build() {
+ # Path to fairsoft installation
+ export SIMPATH=/opt/fairsoft/${fairsoftver}
+ cd ${srcdir}/build
+ make -j$(nproc)
+}
+
+package() {
+ cd ${srcdir}/build
+ make DESTDIR="${pkgdir}/" install
+}
diff --git a/fairroot.install b/fairroot.install
new file mode 100644
index 000000000000..f595e1022f08
--- /dev/null
+++ b/fairroot.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo "Add the following line to your ~/.profile"
+ echo " export FAIRROOTPATH=/opt/fairroot/<fairroot-version>"
+}
+
+post_upgrade() {
+ :
+}
+
+pre_remove() {
+ :
+}
+
+post_remove() {
+ :
+}