summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2018-08-24 06:44:13 +0000
committerAntonio Rojas2018-08-24 06:44:13 +0000
commit9841b5bb6479f97df2c9fd0c6070bb12c674c494 (patch)
treef04b08812c1382abbd679e75d7977f0bb8daaf3e
downloadaur-9841b5bb6479f97df2c9fd0c6070bb12c674c494.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bac9911f52d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = attica-qt4
+ pkgdesc = A Qt4 library that implements the Open Collaboration Services API
+ pkgver = 0.4.2
+ pkgrel = 4
+ url = https://projects.kde.org/projects/frameworks/attica
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ depends = qt4
+ source = http://download.kde.org/stable/attica/attica-0.4.2.tar.bz2
+ md5sums = d62c5c9489a68432e8d990dde7680c24
+
+pkgname = attica-qt4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb872e1d23fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 316578 2018-02-10 01:03:30Z arojas $
+# Maintainer:
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=attica-qt4
+pkgver=0.4.2
+pkgrel=4
+pkgdesc='A Qt4 library that implements the Open Collaboration Services API'
+arch=('x86_64')
+url='https://projects.kde.org/projects/frameworks/attica'
+license=('LGPL')
+depends=('qt4')
+makedepends=('cmake')
+source=("http://download.kde.org/stable/attica/attica-${pkgver}.tar.bz2")
+md5sums=('d62c5c9489a68432e8d990dde7680c24')
+
+prepare() {
+ mkdir build
+}
+
+build() {
+ cd build
+ cmake ../attica-${pkgver} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}