summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-10-05 16:43:11 +0200
committersl1pkn072015-10-05 16:43:11 +0200
commit984d5bd2c0fa080666b987de384d40bbf44b099f (patch)
treec535dcb73f5d1867feff586c4401f4e9da39254b
parent6680e3b3653de7281370157869743d0d3208c182 (diff)
downloadaur-984d5bd2c0fa080666b987de384d40bbf44b099f.tar.gz
Update PKGBUILD
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD24
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6042f7e8ccfd..c83694671c9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vapoursynth-plugin-lsmashsource-git
pkgdesc = Plugin for Vapoursynth: lsmashsource (GIT version)
- pkgver = r783.49b0813
+ pkgver = r804.03117ec
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=167435
arch = i686
@@ -12,7 +12,7 @@ pkgbase = vapoursynth-plugin-lsmashsource-git
provides = vapoursynth-plugin-lsmashsource
conflicts = vapoursynth-plugin-lsmashsource
source = lsmashsource::git+https://github.com/VFR-maniac/L-SMASH-Works.git
- md5sums = SKIP
+ sha1sums = SKIP
pkgname = vapoursynth-plugin-lsmashsource-git
diff --git a/PKGBUILD b/PKGBUILD
index a2ef34e2981e..a4d8f6cc69f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,39 +2,39 @@
_plug=lsmashsource
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r783.49b0813
-_pkgver="$(echo ${pkgver} | cut -d '.' -f1 | tr -d r)"
+pkgver=r804.03117ec
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
-url="http://forum.doom9.org/showthread.php?t=167435"
+url='http://forum.doom9.org/showthread.php?t=167435'
license=('LGPL')
depends=('vapoursynth' 'l-smash-git')
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/VFR-maniac/L-SMASH-Works.git")
-md5sums=('SKIP')
-_gitname="${_plug}"
+sha1sums=('SKIP')
pkgver() {
- cd "${_gitname}"
- echo "r$(git rev-list HEAD 2> /dev/null | wc -l | sed 's/ //g').$(git describe --always)"
+ cd "${_plug}"
+ #echo "$(git describe --long --tags | tr - .)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- rm "${_gitname}/VapourSynth/VapourSynth.h"
+ rm -fr "${_plug}/VapourSynth/VapourSynth.h"
}
build() {
- cd "${_gitname}/VapourSynth"
- ./configure --prefix=/usr --extra-cflags="$(pkg-config --cflags vapoursynth)"
+ cd "${_plug}/VapourSynth"
+ ./configure --prefix=/usr \
+ --extra-cflags="${CFLAGS} $(pkg-config --cflags vapoursynth)" \
+ --extra-ldflags="${LDFLAGS}"
make
}
package(){
- cd "${_gitname}/VapourSynth"
+ cd "${_plug}/VapourSynth"
make DESTDIR="${pkgdir}" install
install -Dm644 README "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
-
}