summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Gust2024-01-28 23:05:03 -0700
committerJeremy Gust2024-01-28 23:05:03 -0700
commit984eba1f4d35d258f075c354ed741a0a9521fe8b (patch)
tree539b8b00365545cd7a28fd768bbf12967d2a502b
parent4e8b873d27a05919580189c02eb2ad762877d7c5 (diff)
downloadaur-984eba1f4d35d258f075c354ed741a0a9521fe8b.tar.gz
Added SPDX
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51d75ab8308f..48af8a2dba52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = slurm
pkgrel = 2
url = https://github.com/mattthias/slurm
arch = x86_64
- license = GPL2
+ license = GPL-2.0-only
makedepends = meson
depends = ncurses
conflicts = slurm-llnl
diff --git a/PKGBUILD b/PKGBUILD
index 076c7308b2fe..ac2db824f9e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,24 +9,24 @@ pkgver=0.4.4
pkgrel=2
pkgdesc="yet another network load monitor"
url="https://github.com/mattthias/slurm"
-license=("GPL2")
+license=("GPL-2.0-only")
arch=('x86_64')
depends=('ncurses')
makedepends=('meson')
conflicts=('slurm-llnl') #both packages have manpage "slurm.1"
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/upstream/${pkgver}.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/upstream/$pkgver.tar.gz")
sha256sums=('2f846c9aa16f86cc0d3832c5cd1122b9d322a189f9e6acf8e9646dee12f9ac02')
build() {
- # Sets CFLAGS to the makepkg.conf default (as of 2023-9-9) without "-fexceptions"
- # as it causes a segfault when slurm is run.
- CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt \
+ # Sets CFLAGS to the makepkg.conf default (as of 2023-9-9) without "-fexceptions"
+ # as it causes a segfault when slurm is run.
+ CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt \
-Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security \
-fstack-clash-protection -fcf-protection"
- arch-meson ${pkgname}-upstream-${pkgver} build
- meson compile -C build
+ arch-meson $pkgname-upstream-$pkgver build
+ meson compile -C build
}
package() {
- meson install -C build --destdir "$pkgdir"
+ meson install -C build --destdir "${pkgdir}"
}