summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-06-25 22:17:52 +0200
committerCarsten Teibes2014-06-25 22:17:52 +0200
commit9863bbdd872ba07961b5008a6b589e9264e8d828 (patch)
tree3c596d8dc2ef488fdcdc2f560545afc2f598f8fa
parent619d0b3af47c79e8d39ea251e39d804ca069bcfc (diff)
downloadaur-9863bbdd872ba07961b5008a6b589e9264e8d828.tar.gz
Cleanup
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD29
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8f91811c470..86540b52ef37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mkxp-git
- pkgdesc = Open source implementation of the Ruby Game Scripting System of RPG Maker XP
- pkgver = r341.51c5ca1
+ pkgdesc = Open source implementation of the Ruby Game Scripting System of RPG Maker XP (development version)
+ pkgver = r403.843a7bf
pkgrel = 1
url = https://github.com/Ancurio/mkxp
install = mkxp.install
@@ -18,7 +18,6 @@ pkgbase = mkxp-git
depends = sdl2_ttf
depends = sdl_sound-patched-hg
depends = pixman
- depends = glew
depends = openal
depends = boost-libs
depends = libgl
diff --git a/PKGBUILD b/PKGBUILD
index e5f5ab3e130e..3c084df3c2a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,41 @@
-# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
-_pkgbase=mkxp
-pkgname=$_pkgbase-git
-pkgver=r341.51c5ca1
+_name=mkxp
+pkgname=$_name-git
+pkgver=r403.843a7bf
pkgrel=1
-pkgdesc="Open source implementation of the Ruby Game Scripting System of RPG Maker XP"
+pkgdesc="Open source implementation of the Ruby Game Scripting System of RPG Maker XP (development version)"
arch=('i686' 'x86_64')
url="https://github.com/Ancurio/mkxp"
license=('GPL2')
depends=('ruby' 'physfs-hg' 'sdl2_image' 'sdl2_ttf' 'sdl_sound-patched-hg'
- 'pixman' 'glew' 'openal' 'boost-libs' 'libgl' 'libsigc++')
+ 'pixman' 'openal' 'boost-libs' 'libgl' 'libsigc++')
makedepends=('git' 'boost' 'cmake' 'mesa' 'vim')
conflicts=('mkxp')
provides=('mkxp')
-install=$_pkgbase.install
-source=($_pkgbase::"git+$url.git")
+install=$_name.install
+source=($_name::"git+$url.git")
md5sums=('SKIP')
pkgver() {
- cd $_pkgbase
-
+ cd $_name
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd $_pkgbase
+ cd $_name
cmake ./ -DMRIVERSION=2.1
make
}
package() {
- cd $_pkgbase
+ cd $_name
# install architecture dependent executeable
- install -Dm755 $_pkgbase.bin.x* "$pkgdir"/usr/bin/$_pkgbase
+ install -Dm755 $_name.bin.x* "$pkgdir"/usr/bin/$_name
# install documentation
- install -Dm644 README.md "$pkgdir"/usr/share/doc/$_pkgbase/README.md
- install -m644 mkxp.conf.sample "$pkgdir"/usr/share/doc/$_pkgbase
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/$_name/README.md
+ install -m644 mkxp.conf.sample "$pkgdir"/usr/share/doc/$_name
}