summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclu2015-06-20 18:16:29 -0600
committerclu2015-06-20 18:16:29 -0600
commit986ac6c2fdf2ee1caa441a7618a7a504ae797d70 (patch)
treefc088bfdf88ccd260f72eaec51c3111870261303
downloadaur-986ac6c2fdf2ee1caa441a7618a7a504ae797d70.tar.gz
Initial import to aur4
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..294c120b438c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = cmpfit
+ pkgdesc = A MINPACK-1 Least Squares Fitting Library in C
+ pkgver = 1.2
+ pkgrel = 2
+ url = http://www.physics.wisc.edu/~craigm/idl/cmpfit.html
+ arch = i686
+ arch = x86_64
+ license = unknown
+ source = http://www.physics.wisc.edu/~craigm/idl/down/cmpfit-1.2.tar.gz
+ md5sums = ea86da19015c4dd456e2a9e3655b1b4d
+
+pkgname = cmpfit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32727aa6e1d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: <clu@eeviac>
+
+pkgname=cmpfit
+pkgver=1.2
+pkgrel=2
+pkgdesc="A MINPACK-1 Least Squares Fitting Library in C"
+url="http://www.physics.wisc.edu/~craigm/idl/cmpfit.html"
+arch=('i686' 'x86_64')
+license=('unknown')
+depends=()
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+source=(http://www.physics.wisc.edu/~craigm/idl/down/$pkgname-$pkgver.tar.gz)
+md5sums=('ea86da19015c4dd456e2a9e3655b1b4d')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ # Install because makefile has no install...
+ mkdir -p $pkgdir/usr/lib
+ install -Dm644 libmpfit.a $pkgdir/usr/lib
+
+ mkdir -p $pkgdir/usr/include
+ install -Dm644 mpfit.h $pkgdir/usr/include
+}