summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-04-02 12:36:11 -0300
committerDaniel Bermond2023-04-02 12:36:11 -0300
commit9878083aac2fec5e72cd3f3b760751589bae672a (patch)
tree25767d2d9c9b64b1773136d93d8d281d1ba54b5b
parent324ca4fca6f0744e75a41a791eb5f2d7d45d5c6c (diff)
downloadaur-9878083aac2fec5e72cd3f3b760751589bae672a.tar.gz
Update to version 4.4.0
-rw-r--r--.SRCINFO6
-rw-r--r--010-astc-encoder-use-shared-library.patch79
-rw-r--r--PKGBUILD19
3 files changed, 11 insertions, 93 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93cabf7789db..d0465d5961db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = astc-encoder
pkgdesc = A tool for compressing and decompressing images using the ASTC texture compression standard
- pkgver = 4.3.1
+ pkgver = 4.4.0
pkgrel = 1
url = https://github.com/ARM-software/astc-encoder/
arch = x86_64
@@ -9,11 +9,9 @@ pkgbase = astc-encoder
makedepends = cmake
makedepends = python
depends = gcc-libs
- source = git+https://github.com/ARM-software/astc-encoder.git#tag=4.3.1
+ source = git+https://github.com/ARM-software/astc-encoder.git#tag=4.4.0
source = git+https://github.com/google/googletest.git
- source = 010-astc-encoder-use-shared-library.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = b17d8f02273a0e58c9055dc5696965b62fbf833923b513d3685eda1af2cf13f4
pkgname = astc-encoder
diff --git a/010-astc-encoder-use-shared-library.patch b/010-astc-encoder-use-shared-library.patch
deleted file mode 100644
index 93a664a53ba2..000000000000
--- a/010-astc-encoder-use-shared-library.patch
+++ /dev/null
@@ -1,79 +0,0 @@
---- a/Source/cmake_core.cmake
-+++ b/Source/cmake_core.cmake
-@@ -26,8 +26,8 @@ project(${ASTC_TARGET})
- set(GNU_LIKE "GNU,Clang,AppleClang")
- set(CLANG_LIKE "Clang,AppleClang")
-
--add_library(${ASTC_TARGET}-static
-- STATIC
-+add_library(${ASTC_TARGET}
-+ SHARED
- astcenc_averages_and_directions.cpp
- astcenc_block_sizes.cpp
- astcenc_color_quantize.cpp
-@@ -52,13 +52,13 @@ add_library(${ASTC_TARGET}-static
- astcenc_weight_align.cpp
- astcenc_weight_quant_xfer_tables.cpp)
-
--target_include_directories(${ASTC_TARGET}-static
-+target_include_directories(${ASTC_TARGET}
- PUBLIC
- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>
- $<INSTALL_INTERFACE:.>)
-
- if(${CLI})
-- add_executable(${ASTC_TARGET}
-+ add_executable(${ASTC_TARGET}-bin
- astcenccli_error_metrics.cpp
- astcenccli_image.cpp
- astcenccli_image_external.cpp
-@@ -67,9 +67,13 @@ if(${CLI})
- astcenccli_toplevel.cpp
- astcenccli_toplevel_help.cpp)
-
-- target_link_libraries(${ASTC_TARGET}
-+ target_link_libraries(${ASTC_TARGET}-bin
- PRIVATE
-- ${ASTC_TARGET}-static)
-+ ${ASTC_TARGET})
-+
-+ set_target_properties(${ASTC_TARGET}-bin
-+ PROPERTIES
-+ OUTPUT_NAME ${ASTC_TARGET})
- endif()
-
- macro(astcenc_set_properties NAME)
-@@ -309,16 +313,16 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
- COMPILE_FLAGS ${EXTERNAL_CXX_FLAGS})
- endif()
-
--astcenc_set_properties(${ASTC_TARGET}-static)
-+astcenc_set_properties(${ASTC_TARGET})
-
-- target_compile_options(${ASTC_TARGET}-static
-+ target_compile_options(${ASTC_TARGET}
- PRIVATE
- $<$<CXX_COMPILER_ID:MSVC>:/W4>)
-
- if(${CLI})
-- astcenc_set_properties(${ASTC_TARGET})
-+ astcenc_set_properties(${ASTC_TARGET}-bin)
-
-- target_compile_options(${ASTC_TARGET}
-+ target_compile_options(${ASTC_TARGET}-bin
- PRIVATE
- $<$<CXX_COMPILER_ID:MSVC>:/W3>)
-
-@@ -329,9 +333,10 @@ if(${CLI})
- astcenccli_version.h
- ESCAPE_QUOTES @ONLY)
-
-- target_include_directories(${ASTC_TARGET}
-+ target_include_directories(${ASTC_TARGET}-bin
- PRIVATE
- ${CMAKE_CURRENT_BINARY_DIR})
-
-- install(TARGETS ${ASTC_TARGET} DESTINATION ${PACKAGE_ROOT})
-+ install(TARGETS ${ASTC_TARGET}-bin DESTINATION ${PACKAGE_ROOT})
-+ install(TARGETS ${ASTC_TARGET} DESTINATION ${CMAKE_INSTALL_LIBDIR})
- endif()
diff --git a/PKGBUILD b/PKGBUILD
index cfa1cd8815b9..6e32329c41df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=astc-encoder
-pkgver=4.3.1
+pkgver=4.4.0
pkgrel=1
pkgdesc='A tool for compressing and decompressing images using the ASTC texture compression standard'
arch=('x86_64')
@@ -10,39 +10,38 @@ license=('Apache')
depends=('gcc-libs')
makedepends=('git' 'cmake' 'python')
source=("git+https://github.com/ARM-software/astc-encoder.git#tag=${pkgver}"
- 'git+https://github.com/google/googletest.git'
- '010-astc-encoder-use-shared-library.patch')
+ 'git+https://github.com/google/googletest.git')
sha256sums=('SKIP'
- 'SKIP'
- 'b17d8f02273a0e58c9055dc5696965b62fbf833923b513d3685eda1af2cf13f4')
+ 'SKIP')
prepare() {
git -C astc-encoder submodule init
git -C astc-encoder config --local submodule.Source/GoogleTest.url "${srcdir}/googletest"
git -C astc-encoder -c protocol.file.allow='always' submodule update
- patch -d astc-encoder -Np1 -i "${srcdir}/010-astc-encoder-use-shared-library.patch"
}
build() {
cmake -B build -S astc-encoder \
+ -G 'Unix Makefiles' \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
+ -DSHAREDLIB:BOOL='ON' \
-DISA_AVX2:BOOL='ON' \
-DISA_SSE41:BOOL='ON' \
-DISA_SSE2:BOOL='ON' \
-DUNITTEST:BOOL='ON' \
-Wno-dev
- make -C build
+ cmake --build build
}
check() {
- make -C build test
+ ctest --test-dir build --output-on-failure
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
install -D -m644 astc-encoder/Source/astcenc.h -t "${pkgdir}/usr/include"
ln -s astcenc-sse2 "${pkgdir}/usr/bin/astcenc"
- ln -s libastcenc-sse2.so "${pkgdir}/usr/lib/libastcenc.so"
+ ln -s libastcenc-sse2-shared.so "${pkgdir}/usr/lib/libastcenc.so"
rm "${pkgdir}/usr/bin"/test-unit*
}