summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcbpark2017-03-15 03:23:15 +0900
committercbpark2017-03-15 03:23:15 +0900
commit9878aa43e64d3ea93ccea55a6a3fe65727d558a9 (patch)
treef6ea20dd2e1099141ad56d5438048bf1de96e5bb
downloadaur-9878aa43e64d3ea93ccea55a6a3fe65727d558a9.tar.gz
addpkg: haskell-threadscope 0.2.7-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3724a35929a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = haskell-threadscope
+ pkgdesc = A graphical viewer for thread profile information generated by the Glasgow Haskell compiler (GHC).
+ pkgver = 0.2.7
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/threadscope
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ depends = ghc>=8.0.1
+ depends = haskell-cairo
+ depends = haskell-ghc-events>=0.4.2
+ depends = haskell-glib
+ depends = haskell-gtk2>=0.12
+ depends = haskell-mtl
+ depends = haskell-pango
+ depends = haskell-text
+ source = https://hackage.haskell.org/packages/archive/threadscope/0.2.7/threadscope-0.2.7.tar.gz
+ sha256sums = cc5653831252d55b3ba7506ea648e770b2c4489cdf4d78828f07dc24ea7ffdb6
+
+pkgname = haskell-threadscope
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3045534774dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Chan Beom Park <cbpark@gmail.com>
+
+_hkgname=threadscope
+pkgname=haskell-threadscope
+pkgver=0.2.7
+pkgrel=1
+pkgdesc="A graphical viewer for thread profile information generated by the Glasgow Haskell compiler (GHC)."
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('custom:BSD3')
+arch=('i686' 'x86_64')
+depends=('ghc>=8.0.1'
+ 'haskell-cairo'
+ 'haskell-ghc-events>=0.4.2'
+ 'haskell-glib'
+ 'haskell-gtk2>=0.12'
+ 'haskell-mtl'
+ 'haskell-pango'
+ 'haskell-text')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha256sums=('cc5653831252d55b3ba7506ea648e770b2c4489cdf4d78828f07dc24ea7ffdb6')
+
+build() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+
+ runhaskell Setup configure -O --enable-library-profiling --enable-shared \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
+ --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+}
+
+package() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}