summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcouney2021-08-04 12:36:48 +0200
committerMarcouney2021-08-04 12:36:48 +0200
commit98807af45393df5ceb53d7196e3b90daf691b6c6 (patch)
tree80f0cb9066367c05547f91983fbd05bb09cd38c0
downloadaur-98807af45393df5ceb53d7196e3b90daf691b6c6.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--010-qt-jpegxl-image-plugin-allow-qt6-coinstall.patch39
-rw-r--r--PKGBUILD45
3 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6bba40ae6383
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = qt5-jpegxl-image-plugin-git
+ pkgdesc = Qt5 plug-in to allow Qt and KDE based applications to read/write JXL images
+ pkgver = 0.2.0.r0.geb424dd
+ pkgrel = 1
+ url = https://github.com/novomesk/qt-jpegxl-image-plugin
+ arch = x86_64
+ license = GPL3
+ checkdepends = appstream
+ makedepends = git
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ makedepends = highway
+ depends = libjxl
+ depends = qt5-base
+ provides = qt5-jpegxl-image-plugin
+ conflicts = qt5-jpegxl-image-plugin
+ options = !emptydirs
+ source = git+https://github.com/novomesk/qt-jpegxl-image-plugin.git
+ source = 010-qt-jpegxl-image-plugin-allow-qt6-coinstall.patch
+ sha256sums = SKIP
+ sha256sums = 05d7106ddc07a91ae3dccaa8815cf74fa9aef87c12e2961dfadc1240c5f07790
+
+pkgname = qt5-jpegxl-image-plugin-git
diff --git a/010-qt-jpegxl-image-plugin-allow-qt6-coinstall.patch b/010-qt-jpegxl-image-plugin-allow-qt6-coinstall.patch
new file mode 100644
index 000000000000..2289df0af91a
--- /dev/null
+++ b/010-qt-jpegxl-image-plugin-allow-qt6-coinstall.patch
@@ -0,0 +1,39 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -20,7 +20,15 @@ include(KDECMakeSettings)
+ include(CheckIncludeFiles)
+
+ set(REQUIRED_QT_VERSION 5.14.0)
+-find_package(Qt5Gui ${REQUIRED_QT_VERSION} REQUIRED NO_MODULE)
++string(REGEX MATCH "^[0-9]" REQUIRED_QT_MAJOR "${REQUIRED_QT_VERSION}")
++set(QT_MAJOR ${REQUIRED_QT_MAJOR} CACHE STRING "Qt major version to use")
++
++if(QT_MAJOR GREATER_EQUAL ${REQUIRED_QT_MAJOR})
++ message(STATUS "Info: building with Qt${QT_MAJOR}")
++ find_package(Qt${QT_MAJOR}Gui ${REQUIRED_QT_VERSION} REQUIRED NO_MODULE)
++else()
++ message(FATAL_ERROR "Qt major version must be at least ${REQUIRED_QT_MAJOR}")
++endif()
+
+ include(FindPkgConfig)
+ pkg_check_modules(LibJXL REQUIRED IMPORTED_TARGET libjxl>=0.5.0)
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -18,7 +18,7 @@ function(kimageformats_add_plugin plugin)
+ add_library(${plugin} MODULE ${KIF_ADD_PLUGIN_SOURCES})
+ set_property(TARGET ${plugin} APPEND PROPERTY AUTOGEN_TARGET_DEPENDS ${json})
+ set_target_properties(${plugin} PROPERTIES LIBRARY_OUTPUT_DIRECTORY "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/imageformats")
+- target_link_libraries(${plugin} Qt5::Gui)
++ target_link_libraries(${plugin} Qt${QT_MAJOR}::Gui)
+ install(TARGETS ${plugin} DESTINATION ${KDE_INSTALL_QTPLUGINDIR}/imageformats)
+ endfunction()
+
+@@ -27,7 +27,7 @@ endfunction()
+ if (LibJXL_FOUND)
+ kimageformats_add_plugin(libqjpegxl JSON "jpegxl.json" SOURCES "main.cpp" "qjpegxlhandler.cpp")
+ target_link_libraries(libqjpegxl PkgConfig::LibJXL PkgConfig::LibJXLThreads)
+- install(FILES jxl.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR}/qimageioplugins/)
++ install(FILES jxl.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR}/qimageioplugins/ RENAME jxl_qt${QT_MAJOR}.desktop)
+ endif()
+
+ ##################################
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d3329c7ffca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Marc ROGER de CAMPAGNOLLE <fora at mrdc dot fr>
+
+pkgname=qt5-jpegxl-image-plugin-git
+_pkgname=qt-jpegxl-image-plugin
+pkgver=0.2.0.r0.geb424dd
+pkgrel=1
+pkgdesc='Qt5 plug-in to allow Qt and KDE based applications to read/write JXL images'
+arch=('x86_64')
+url="https://github.com/novomesk/$_pkgname"
+license=('GPL3')
+depends=('libjxl' 'qt5-base')
+makedepends=('git' 'cmake' 'extra-cmake-modules' 'highway')
+checkdepends=('appstream')
+provides=('qt5-jpegxl-image-plugin')
+conflicts=('qt5-jpegxl-image-plugin')
+options=('!emptydirs')
+source=("git+$url.git"
+ "010-$_pkgname-allow-qt6-coinstall.patch")
+sha256sums=('SKIP'
+ '05d7106ddc07a91ae3dccaa8815cf74fa9aef87c12e2961dfadc1240c5f07790')
+
+pkgver() {
+ git -C $_pkgname describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
+
+prepare() {
+ patch -d $_pkgname -Np1 -i "$srcdir/010-$_pkgname-allow-qt6-coinstall.patch"
+}
+
+build() {
+ cmake -B build -S $_pkgname \
+ -DCMAKE_BUILD_TYPE:STRING='None' \
+ -DCMAKE_INSTALL_PREFIX:PATH='/usr' \
+ -DQT_MAJOR:STRING='5' \
+ -Wno-dev
+ make -C build
+}
+
+check() {
+ make -C build test
+}
+
+package() {
+ make -C build DESTDIR="$pkgdir" install
+}