summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-03-11 18:45:53 +0100
committerPhilipp A2019-03-11 18:45:53 +0100
commit98afe288f21436ebdfe503892c995de587f6c2be (patch)
treea15812c3db178d5084b08e709eaadf2f9923a18f
parent15a82aef1ae1a4c4d26f4f1e1e10b5dfb30a5896 (diff)
downloadaur-98afe288f21436ebdfe503892c995de587f6c2be.tar.gz
install-wheel-scripts
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b40cf22f2c8e..b59a687b2494 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = python-wheel-inspect
pkgdesc = Extract information from wheels
pkgver = 1.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jwodder/wheel-inspect
arch = any
license = MIT
+ makedepends = install-wheel-scripts
depends = python
depends = python-attrs
depends = python-headerparser
diff --git a/PKGBUILD b/PKGBUILD
index 5644d955cc13..5136bcd04ad7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
_name=wheel-inspect
pkgname=python-$_name
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Extract information from wheels'
arch=(any)
url="https://github.com/jwodder/$_name"
license=(MIT)
depends=(python python-attrs python-headerparser python-packaging python-property-manager python-readme-renderer python-setuptools)
+makedepends=(install-wheel-scripts)
_pyarch=py3
_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
@@ -19,10 +20,5 @@ package() {
local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
mkdir -p "$site"
unzip "$_wheel" -d "$site"
-
- cat >wheel2json.sh <<-EOF
- #!/bin/sh
- exec python3 -m wheel_inspect "\$@"
- EOF
- install -Dm755 wheel2json.sh "$pkgdir/usr/bin/wheel2json"
+ install-wheel-scripts --prefix="$pkgdir/usr" "$_wheel"
}