summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Anderson2021-02-12 12:07:04 -0500
committerSean Anderson2021-02-12 12:07:04 -0500
commit98bf720c95c1dfbb5750743b96be3d0bc378c29c (patch)
tree7eb483d54bd1211894dbaa1be6ac8546d254aef4
downloadaur-98bf720c95c1dfbb5750743b96be3d0bc378c29c.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD43
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2bc09ebe551
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = arch-test-bin
+ pkgdesc = detect architectures supported by your machine/kernel
+ pkgver = 0.17
+ pkgrel = 1
+ url = https://github.com/kilobyte/arch-test/
+ arch = any
+ license = MIT
+ depends = bash
+ depends = perl
+ source = http://ftp.debian.org/debian/pool/main/a/arch-test/arch-test_0.17-1_all.deb
+ md5sums = 8c5265e8eb8b4debaa0d4178d495c9a0
+
+pkgname = arch-test-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4dca0084aab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+_pkgname=arch-test
+pkgname=${_pkgname}-bin
+pkgver=0.17
+_debrel=1
+pkgrel=1
+epoch=
+pkgdesc="detect architectures supported by your machine/kernel"
+arch=('any')
+url="https://github.com/kilobyte/arch-test/"
+license=('MIT')
+groups=()
+depends=('bash' 'perl')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("http://ftp.debian.org/debian/pool/main/a/arch-test/${_pkgname}_$pkgver-${_debrel}_all.deb")
+noextract=()
+md5sums=('8c5265e8eb8b4debaa0d4178d495c9a0')
+validpgpkeys=()
+
+prepare() {
+ tar -xf data.tar.xz
+}
+
+package() {
+ cp -a usr $pkgdir
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname
+ mv $pkgdir/usr/share/doc/arch-test/copyright $pkgdir/usr/share/licenses/$pkgname
+ rm -rf $pkgdir/usr/share/{doc,lintian}
+}