summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorannguyenfoss2019-10-28 20:09:31 +0700
committerannguyenfoss2019-10-28 20:09:31 +0700
commit98c14eecc21e56214d6944449d9bbf2cc92254f4 (patch)
tree98c517871cc140906524e1e64399377fe7d64e10
parentdce23c79e4e394109b335e98cced4bbbfac05b8a (diff)
downloadaur-98c14eecc21e56214d6944449d9bbf2cc92254f4.tar.gz
Updated to 4.1. Updated GPG keys and SHA512SUM.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ad7df1f4ef7..796db52c14ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Fri Nov 16 18:28:31 UTC 2018
pkgbase = systemtap
- pkgdesc = provides infrastructure to simplify the gathering of information about the running system.
- pkgver = 4.0
- pkgrel = 2
+ pkgdesc = Infrastructure to simplify the gathering of information about the running Linux system
+ pkgver = 4.1
+ pkgrel = 1
url = http://sourceware.org/systemtap/
install = systemtap.install
arch = x86_64
@@ -16,10 +14,11 @@ pkgbase = systemtap
depends = python2
depends = cpio
optdepends = sqlite3: for storing results in a database
- source = systemtap-4.0.tar.gz::https://sourceware.org/systemtap/ftp/releases/systemtap-4.0.tar.gz
- source = systemtap-4.0.tar.gz.asc::https://sourceware.org/systemtap/ftp/releases/systemtap-4.0.tar.gz.asc
- sha512sums = 66b5ba1902ed974101429dce9fee849273d3dc64e862c057177d158c5f284cc93299819ee8ee49d4bd3b7ff47a3512b1c68b74cad374147ce67fa406c7518c79
- sha512sums = SKIP
+ source = systemtap-4.1.tar.gz::https://sourceware.org/systemtap/ftp/releases/systemtap-4.1.tar.gz
+ source = systemtap-4.1.tar.gz.asc::https://sourceware.org/systemtap/ftp/releases/systemtap-4.1.tar.gz.asc
+ validpgpkeys = F75E6545B9F8AA15AA932A444DE16D68FDBFFFB8
+ sha512sums = fbd606d9842ac63af6e607613a112b08d7593da74ad0398716cdc46f74a977a8e6b9fae92e1f63779ccfc94cffa25f29dee2ae44f67ecc4cedae630e50a2e7b6
+ sha512sums = 755a11b6024bb15c6415532352fd62a824266edeb5ab3e1ef6cfa31259f8bf7d9a92fcf7476c307cd7d4188ff20cefe86558b2a6e4c099987e1041bd1f98031e
pkgname = systemtap
diff --git a/PKGBUILD b/PKGBUILD
index ce7671095266..816495e0caa1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer : George Angelopoulos <george@usermod.net>
-# Contributor : Christian Rebischke <Chris.Rebischke@archlinux.org>
-# Contributor : dront78 <dront78@gmail.com>
+# Maintainer: An Nguyen (stk) <an@linux.com>
+# Original Maintainer: George Angelopoulos <george@usermod.net>
+# Original Maintainer: Christian Rebischke <Chris.Rebischke@archlinux.org>
+# Original Maintainer: dront78 <dront78@gmail.com>
pkgname=systemtap
-pkgver=4.0
-pkgrel=2
-pkgdesc="provides infrastructure to simplify the gathering of information about the running system."
+pkgver=4.1
+pkgrel=1
+pkgdesc="Infrastructure to simplify the gathering of information about the running Linux system"
url="http://sourceware.org/systemtap/"
arch=('x86_64' 'i686')
license=('GPL')
@@ -14,11 +15,10 @@ optdepends=('sqlite3: for storing results in a database')
source=("${pkgname}-${pkgver}.tar.gz::https://sourceware.org/systemtap/ftp/releases/${pkgname}-${pkgver}.tar.gz"
"${pkgname}-${pkgver}.tar.gz.asc::https://sourceware.org/systemtap/ftp/releases/${pkgname}-${pkgver}.tar.gz.asc"
)
-sha512sums=('66b5ba1902ed974101429dce9fee849273d3dc64e862c057177d158c5f284cc93299819ee8ee49d4bd3b7ff47a3512b1c68b74cad374147ce67fa406c7518c79'
- 'SKIP')
+sha512sums=('fbd606d9842ac63af6e607613a112b08d7593da74ad0398716cdc46f74a977a8e6b9fae92e1f63779ccfc94cffa25f29dee2ae44f67ecc4cedae630e50a2e7b6'
+ '755a11b6024bb15c6415532352fd62a824266edeb5ab3e1ef6cfa31259f8bf7d9a92fcf7476c307cd7d4188ff20cefe86558b2a6e4c099987e1041bd1f98031e')
install='systemtap.install'
-validpgpkeys=('5D38116FA4D3A7CC77E378D37E83610126DCC2E8')
-
+validpgpkeys=('F75E6545B9F8AA15AA932A444DE16D68FDBFFFB8') # "Serhei Makarov (for Red Hat 2018..onwards) <smakarov@redhat.com>"
build() {
cd "${pkgname}-${pkgver}"
@@ -41,5 +41,5 @@ package() {
make DESTDIR="${pkgdir}" install
rmdir "${pkgdir}/var/run/stap-server/"
rmdir "${pkgdir}/var/run/"
+ rm -r "${pkgdir}/usr/include"
}
-