summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-07-14 18:18:12 +0200
committerhaawda2017-07-14 18:18:12 +0200
commit99205e8f40f8fcbd8a93221c8450064acf9836d0 (patch)
tree6cde78b83e81502cfbf704d4a0aa4255532e42d7
downloadaur-99205e8f40f8fcbd8a93221c8450064acf9836d0.tar.gz
initial upload
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
-rw-r--r--config.h65
3 files changed, 118 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..292d41445802
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Fri Jul 14 16:17:47 UTC 2017
+pkgbase = tabbed-vain
+ pkgdesc = Suckless tabbed modified to suit the author's needs
+ pkgver = 0.6r37
+ pkgrel = 1
+ url = https://github.com/vain/tabbed-vain.git
+ arch = i686
+ arch = x86_64
+ license = custom:MIT/X
+ makedepends = git
+ depends = libxft
+ provides = tabbed
+ conflicts = tabbed
+ source = git+https://github.com/vain/tabbed-vain.git#commit=b98fd6d9015323c57904be9c3529038e1e91f6ea
+ source = config.h
+ md5sums = SKIP
+ md5sums = 061c739dc784bf74e92bd5b7a1100623
+
+pkgname = tabbed-vain
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09fd74f309dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: totoloco <totoloco at gmx>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=tabbed-vain
+pkgver=0.6r37
+pkgrel=1
+pkgdesc="Suckless tabbed modified to suit the author's needs"
+arch=('i686' 'x86_64')
+url='https://github.com/vain/tabbed-vain.git'
+license=('custom:MIT/X')
+depends=('libxft')
+makedepends=('git')
+conflicts=('tabbed')
+provides=('tabbed')
+source=("git+https://github.com/vain/tabbed-vain.git#commit=b98fd6d9015323c57904be9c3529038e1e91f6ea"
+ 'config.h')
+md5sums=('SKIP'
+ '061c739dc784bf74e92bd5b7a1100623')
+
+build() {
+ cd "${pkgname}"
+ cp "${srcdir}/config.h" config.h
+ make
+}
+
+package() {
+ cd "${pkgname}"
+
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+ install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/config.h b/config.h
new file mode 100644
index 000000000000..6c23a81175fb
--- /dev/null
+++ b/config.h
@@ -0,0 +1,65 @@
+/* See LICENSE file for copyright and license details. */
+
+/* appearance */
+
+static const char font[] = "Fira Mono for Powerline:pixelsize=12";
+static const char* normbgcolor = "#222222";
+static const char* normfgcolor = "#cccccc";
+static const char* nonecolor = "#cccccc";
+static const char* linecolor = "#cccccc";
+static const char* selbgcolor = "#555555";
+static const char* selfgcolor = "#ffffff";
+static const char* urgbgcolor = "#111111";
+static const char* urgfgcolor = "#cc0000";
+static const char before[] = "<";
+static const char after[] = ">";
+static const char titletrim[] = "...";
+static const int tabwidth = 200;
+static const Bool foreground = True;
+static Bool urgentswitch = False;
+
+/*
+ * Where to place a new tab when it is opened. When npisrelative is True,
+ * then the current position is changed + newposition. If npisrelative
+ * is False, then newposition is an absolute position.
+ */
+static int newposition = 0;
+static Bool npisrelative = False;
+
+#define SETPROP(p) { \
+ .v = (char *[]){ "/bin/sh", "-c", \
+ "prop=\"`xwininfo -children -id $1 | grep '^ 0x' | sed -e's@^ *\\(0x[0-9a-f]*\\) \"\\([^\"]*\\)\".*@\\1 \\2@' | xargs -0 printf %b | dmenu -l 10`\" &&" \
+ "xprop -id $1 -f $0 8s -set $0 \"$prop\"", \
+ p, winid, NULL \
+ } \
+}
+
+#define MODKEY ControlMask
+static Key keys[] = { \
+ /* modifier key function argument */
+ { MODKEY|ShiftMask, XK_Return, focusonce, { 0 } },
+ { MODKEY|ShiftMask, XK_Return, spawn, { 0 } },
+ { MODKEY, XK_t, spawn, SETPROP("_TABBED_SELECT_TAB") },
+
+ { MODKEY|ShiftMask, XK_l, rotate, { .i = +1 } },
+ { MODKEY|ShiftMask, XK_h, rotate, { .i = -1 } },
+ { MODKEY|ShiftMask, XK_j, movetab, { .i = -1 } },
+ { MODKEY|ShiftMask, XK_k, movetab, { .i = +1 } },
+ { MODKEY, XK_Tab, rotate, { .i = 0 } },
+
+ { MODKEY, XK_1, move, { .i = 0 } },
+ { MODKEY, XK_2, move, { .i = 1 } },
+ { MODKEY, XK_3, move, { .i = 2 } },
+ { MODKEY, XK_4, move, { .i = 3 } },
+ { MODKEY, XK_5, move, { .i = 4 } },
+ { MODKEY, XK_6, move, { .i = 5 } },
+ { MODKEY, XK_7, move, { .i = 6 } },
+ { MODKEY, XK_8, move, { .i = 7 } },
+ { MODKEY, XK_9, move, { .i = 8 } },
+ { MODKEY, XK_0, move, { .i = 9 } },
+
+ { MODKEY, XK_q, killclient, { 0 } },
+
+ { 0, XK_F11, fullscreen, { 0 } },
+};
+