summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2019-12-20 10:26:19 +1100
committerLuis Aranguren2019-12-20 10:26:19 +1100
commit992293a3e9dd603f46394950243eb1c250fb1bed (patch)
tree4691461e99b386bc7b0125b0ee7ee56d5c254b5f
parent39bbcc3a29e8729dc544a85796b9e6f2a21b79c3 (diff)
downloadaur-992293a3e9dd603f46394950243eb1c250fb1bed.tar.gz
pkgrel=3, fixed conflicts, updated zoneminder.install
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--zoneminder.install26
3 files changed, 15 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9bbff27da679..431b76ddd682 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zoneminder-git
pkgdesc = A complete surveillance solution allowing capture, analysis, recording and monitoring of any CCTV or security cameras
pkgver = 1.33.15.r14276.5e4c3e1ed
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ZoneMinder/ZoneMinder
install = zoneminder.install
arch = x86_64
@@ -47,7 +47,7 @@ pkgbase = zoneminder-git
depends = mariadb
optdepends = apache: alternative web server
optdepends = vlc: provides libvlc (may achieve better performance with some camera models)
- conflicts = zoneminder-git
+ conflicts = zoneminder
backup = etc/nginx/sites-available/zoneminder.conf
backup = etc/httpd/conf/extra/zoneminder.conf
backup = etc/php/conf.d/zoneminder.ini
diff --git a/PKGBUILD b/PKGBUILD
index 9ac81834425d..ee9368c5964c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,7 +35,7 @@
pkgname=zoneminder-git
_pkgname=zoneminder
pkgver=1.33.15.r14276.5e4c3e1ed
-pkgrel=2
+pkgrel=3
pkgdesc='A complete surveillance solution allowing capture, analysis, recording and monitoring of any CCTV or security cameras'
arch=('x86_64')
url='https://github.com/ZoneMinder/ZoneMinder'
@@ -64,7 +64,7 @@ depends=('polkit' 'ffmpeg' 'libmp4v2'
makedepends=('cmake')
optdepends=('apache: alternative web server'
'vlc: provides libvlc (may achieve better performance with some camera models)')
-conflicts=('zoneminder-git')
+conflicts=('zoneminder')
backup=("etc/nginx/sites-available/$_pkgname.conf"
"etc/httpd/conf/extra/$_pkgname.conf"
"etc/php/conf.d/$_pkgname.ini")
diff --git a/zoneminder.install b/zoneminder.install
index 8e81d10c2545..79169766a959 100644
--- a/zoneminder.install
+++ b/zoneminder.install
@@ -39,33 +39,29 @@ post_install() {
Zoneminder database setup:
--------------------------
Initialize and start mariadb if you haven't done it already https://wiki.archlinux.org/index.php/MariaDB#Installation
+ "sudo mariadb-install-db --user=mysql --basedir=/usr --datadir=/var/lib/mysql"
+ "systemctl start mariadb.service"
Zoneminder operation requires a database named 'zm' which is defined in /usr/share/zoneminder/db/zm_create.sql
Create the Zoneminder database (with a password):
- "mysqladmin --defaults-file=/etc/my.cnf -p -f reload"
- "cat /usr/share/zoneminder/db/zm_create.sql | mysql --defaults-file=/etc/my.cnf -p"
- "echo 'grant lock tables, alter,select,insert,update,delete on zm.* to 'zmuser'@localhost identified by "zmpass";' | mysql --defaults-file=/etc/my.cnf -p mysql"
+ "sudo mysqladmin --defaults-file=/etc/my.cnf -p -f reload"
+ "cat /usr/share/zoneminder/db/zm_create.sql | sudo mysql --defaults-file=/etc/my.cnf -p"
+ "echo 'grant lock tables, alter,select,insert,update,delete on zm.* to 'zmuser'@localhost identified by "zmpass";' | sudo mysql --defaults-file=/etc/my.cnf -p mysql"
(or without a password):
- "mysqladmin --defaults-file=/etc/my.cnf -f reload"
- "cat /usr/share/zoneminder/db/zm_create.sql | mysql --defaults-file=/etc/my.cnf"
- "echo 'grant lock tables, alter,select,insert,update,delete on zm.* to 'zmuser'@localhost identified by "zmpass";' | mysql --defaults-file=/etc/my.cnf mysql"
+ "sudo mysqladmin --defaults-file=/etc/my.cnf -f reload"
+ "cat /usr/share/zoneminder/db/zm_create.sql | sudo mysql --defaults-file=/etc/my.cnf"
+ "echo 'grant lock tables, alter,select,insert,update,delete on zm.* to 'zmuser'@localhost identified by "zmpass";' | sudo mysql --defaults-file=/etc/my.cnf mysql"
PHP configuration
-----------------
- * Check and make sure these are uncommented in /etc/php/php.ini:
- extension=ftp
- extension=gd
- extension=gettext
- extension=pdo_mysql
- extension=sockets
- extension=zip
- * Set your timezone in php.ini:
+
+ * Set your timezone in PHP configuration file /etc/php/conf.d/zoneminder.ini:
date.timezone = <your_country>/<your_city>
Nginx configuration
-------------------
sudo mkdir /etc/nginx/sites-enabled
- sudo mv /etc/nginx/sites-available/zoneminder.conf /etc/nginx/sites-enabled/
+ sudo ln -s /etc/nginx/sites-available/zoneminder.conf /etc/nginx/sites-enabled/zoneminder.conf
Add "include /etc/nginx/sites-enabled/zoneminder.conf;" to the http section in /etc/nginx/nginx.conf
Apache configuration