summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2020-01-29 17:35:12 +0100
committerPieter Goetschalckx2020-01-29 17:36:23 +0100
commit9943dbd26250082686604d936afce30105e1e314 (patch)
tree346da385aa390b3c9cfee6839eecca16f13d2521
parentfe3f2ba7230422a5d025b995bf63896e8e7f077e (diff)
downloadaur-9943dbd26250082686604d936afce30105e1e314.tar.gz
Build from source
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD31
2 files changed, 25 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b17ac1d6007..20f50794b6ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = fx_cast
pkgdesc = Implementation of the Chrome Sender API (Chromecast) within Firefox
pkgver = 0.0.5
- pkgrel = 1
+ pkgrel = 2
url = https://hensm.github.io/fx_cast/
arch = x86_64
- groups =
license = MIT
+ makedepends = npm
depends = nodejs
+ conflicts = fx_cast-bin
options = !strip
- options = !emptydirs
- source = https://github.com/hensm/fx_cast/releases/download/v0.0.5/fx_cast_bridge-0.0.5-x64.deb
- sha512sums = 1fbdaaea9a49f8e6282e965e5a61f88b4b1a5039251c97e39e62f81e792f9c82392e6a717f6ea52feb1771c2f373687cf95988fb4e4635e2ebd9b11a53644c7d
+ source = https://github.com/hensm/fx_cast/archive/v0.0.5.tar.gz
+ sha256sums = 5636939846247bee0c7c14689a2daed717ac700f72d85e71ae152a5e44543ea4
pkgname = fx_cast
diff --git a/PKGBUILD b/PKGBUILD
index 6f119351210d..abd45b1cea57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,32 @@
-# Generated by debtap
-# Maintainer: csicar
+# Maintainer: 314eter
# Contributor: csicar
+
pkgname=fx_cast
pkgver=0.0.5
-pkgrel=1
+pkgrel=2
pkgdesc="Implementation of the Chrome Sender API (Chromecast) within Firefox"
arch=('x86_64')
url="https://hensm.github.io/fx_cast/"
license=('MIT')
-groups=('')
depends=('nodejs')
-options=('!strip' '!emptydirs')
-source=("https://github.com/hensm/fx_cast/releases/download/v0.0.5/fx_cast_bridge-0.0.5-x64.deb")
-sha512sums=('1fbdaaea9a49f8e6282e965e5a61f88b4b1a5039251c97e39e62f81e792f9c82392e6a717f6ea52feb1771c2f373687cf95988fb4e4635e2ebd9b11a53644c7d')
+makedepends=('npm')
+conflicts=('fx_cast-bin')
+options=('!strip')
+source=("https://github.com/hensm/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('5636939846247bee0c7c14689a2daed717ac700f72d85e71ae152a5e44543ea4')
+
+build() {
+ cd "${pkgname}-${pkgver}"
-package(){
+ npm install
+ npm run build:app
+ sed -i 's#"path":.*$#"path": "/usr/bin/fx_cast_bridge"#' dist/app/fx_cast_bridge.json
+}
- # Extract package data
- tar xf data.tar.xz -C "${pkgdir}"
- echo "fx_cast: Do not forget to install the firefox extension"
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 dist/app/fx_cast_bridge "${pkgdir}/usr/bin/fx_cast_bridge"
+ install -Dm644 dist/app/fx_cast_bridge.json "${pkgdir}/usr/lib/mozilla/native-messaging-hosts/fx_cast_bridge.json"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}