summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandalenavals2017-10-30 10:04:23 -0200
committerandalenavals2017-10-30 10:04:23 -0200
commit99504e75beb76bcf6f314d4644dc97cb2d098335 (patch)
tree2a39aa23809cfa317b85df7394b8b38f01c708cc
downloadaur-99504e75beb76bcf6f314d4644dc97cb2d098335.tar.gz
Copyright (c) 1998-2016, Mike Jarvis
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD57
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..456a08df455e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = tmv
+ pkgdesc = A fast, intuitive linear algebra library for C++
+ pkgver = r99.6bdc079
+ pkgrel = 1
+ url = https://github.com/rmjarvis/tmv/
+ arch = x86_64
+ license = unknown
+ makedepends = git
+ depends = scons
+ depends = cblas
+ source = tmv-r99.6bdc079::git+https://github.com/rmjarvis/tmv/
+ md5sums = SKIP
+
+pkgname = tmv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..09d499e04fed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
+# Contributor: M. Jarvis
+pkgname=tmv
+pkgver=r99.6bdc079
+pkgrel=1
+#epoch=
+
+pkgdesc=" A fast, intuitive linear algebra library for C++ "
+
+
+arch=('x86_64')
+url="https://github.com/rmjarvis/tmv/"
+license=('unknown')
+groups=()
+depends=('scons' 'cblas')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver::git+${url}")
+#noextract=()
+md5sums=('SKIP')
+#validpgpkeys=()
+
+
+build() {
+ cd "$src"
+ cd "$pkgname-$pkgver"
+ scons PREFIX=/usr
+}
+
+
+pkgver() {
+ cd "$pkgname-$pkgver"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "$src"
+ cd "$pkgname-$pkgver"
+ scons PREFIX=$pkgdir/usr install
+ # scons install PREFIX=/data
+ # scons install --prefix "${pkgdir}"
+
+}