summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristiaan Biesterbosch2023-11-10 11:32:52 +0100
committerChristiaan Biesterbosch2023-11-10 11:32:52 +0100
commit9988a8c0ff131c9632bd2a1a47a30f15a0d5328b (patch)
treed0aa3576926876829b62598ba28559b89c04fb3f
parent407e74b37ebe2b126337613a2f9543464b5fc9d2 (diff)
downloadaur-9988a8c0ff131c9632bd2a1a47a30f15a0d5328b.tar.gz
v16.1.5
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD15
2 files changed, 21 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0eee7f0ba2f..efc64d1480fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-frida
pkgdesc = Inject JavaScript to explore native apps on Windows, Mac, Linux, iOS and Android. Python 3 version from PyPi
- pkgver = 16.1.4
+ pkgver = 16.1.5
pkgrel = 1
url = https://www.frida.re
arch = i686
@@ -9,21 +9,22 @@ pkgbase = python-frida
arch = aarch64
license = custom:wxWindows Library License, Version 3.1
depends = python
+ depends = python-setuptools
optdepends = python-typing_extensions: for Python <3.8
optdepends = rustup: for injecting Rust code into targets
conflicts = python2-frida
- noextract = frida-core-devkit-16.1.4-linux.tar.xz
- source = https://files.pythonhosted.org/packages/source/f/frida/frida-16.1.4.tar.gz
+ noextract = frida-core-devkit-16.1.5-linux.tar.xz
+ source = https://files.pythonhosted.org/packages/source/f/frida/frida-16.1.5.tar.gz
source = COPYING
- sha256sums = b2d3a22f8422cd9379ee2a3ca870e50cdb1706cfa48be9587bf835d63e51e582
+ sha256sums = 97d5c3cd0db16a144a769e6f6129671b12dc72e31b6017bc56fc3c9137c2d511
sha256sums = 5ea1544b51a28bc823b03159190d4108f9fb4f4ef912389f5137c6d295e175b2
- source_i686 = frida-core-devkit-16.1.4-linux.tar.xz::https://github.com/frida/frida/releases/download/16.1.4/frida-core-devkit-16.1.4-linux-x86.tar.xz
- sha256sums_i686 = 00fc9b22d91ed3a1fb18d81ff59626cc1b1835a0752a99d43355f8b977a246c5
- source_x86_64 = frida-core-devkit-16.1.4-linux.tar.xz::https://github.com/frida/frida/releases/download/16.1.4/frida-core-devkit-16.1.4-linux-x86_64.tar.xz
- sha256sums_x86_64 = 0b43f204da687d259a84e0374def8b24409aaf4414b2be24bc82954bd34c2111
- source_armv7h = frida-core-devkit-16.1.4-linux.tar.xz::https://github.com/frida/frida/releases/download/16.1.4/frida-core-devkit-16.1.4-linux-armhf.tar.xz
- sha256sums_armv7h = 24362b999934c13712cc3439fd538ab538088236e7f139b5b912c2e0976c9958
- source_aarch64 = frida-core-devkit-16.1.4-linux.tar.xz::https://github.com/frida/frida/releases/download/16.1.4/frida-core-devkit-16.1.4-linux-arm64.tar.xz
- sha256sums_aarch64 = 42782f93c2959de5e63759682a89360e8f002f18500099a775f8ecde14f4cc2d
+ source_i686 = frida-core-devkit-16.1.5-linux.tar.xz::https://github.com/frida/frida/releases/download/16.1.5/frida-core-devkit-16.1.5-linux-x86.tar.xz
+ sha256sums_i686 = 98a8f88fbbbe0d554dd8f2851329e7171b40722555f0c88133c6da82f23ebca0
+ source_x86_64 = frida-core-devkit-16.1.5-linux.tar.xz::https://github.com/frida/frida/releases/download/16.1.5/frida-core-devkit-16.1.5-linux-x86_64.tar.xz
+ sha256sums_x86_64 = 129777ad18e5f7aad94ed689710c2e5e2369cdbfc138e88746a63299838ae0c2
+ source_armv7h = frida-core-devkit-16.1.5-linux.tar.xz::https://github.com/frida/frida/releases/download/16.1.5/frida-core-devkit-16.1.5-linux-armhf.tar.xz
+ sha256sums_armv7h = a4b71545d882358a23d290b83527bbf0b58cc5dedcb94d51f2a80d1ef3ac8bac
+ source_aarch64 = frida-core-devkit-16.1.5-linux.tar.xz::https://github.com/frida/frida/releases/download/16.1.5/frida-core-devkit-16.1.5-linux-arm64.tar.xz
+ sha256sums_aarch64 = e843f1a584cb1900761ccf940788609911c8dda5bf0237d669fe09947cb4f603
pkgname = python-frida
diff --git a/PKGBUILD b/PKGBUILD
index 1de0a006b2e0..0ea4af9e8dae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,14 @@
_pkgname=frida
pkgname=python-$_pkgname
-pkgver=16.1.4
+pkgver=16.1.5
pkgrel=1
pkgdesc="Inject JavaScript to explore native apps on Windows, Mac, Linux, iOS and Android. Python 3 version from PyPi"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://www.frida.re"
license=('custom:wxWindows Library License, Version 3.1')
-depends=('python')
+depends=('python'
+ 'python-setuptools')
optdepends=('python-typing_extensions: for Python <3.8'
'rustup: for injecting Rust code into targets')
# Sourced from https://pypi.org/project/frida/#files
@@ -21,12 +22,12 @@ source_i686=("frida-core-devkit-${pkgver}-linux.tar.xz::https://github.com/frida
source_x86_64=("frida-core-devkit-${pkgver}-linux.tar.xz::https://github.com/frida/frida/releases/download/${pkgver}/frida-core-devkit-${pkgver}-linux-x86_64.tar.xz")
source_armv7h=("frida-core-devkit-${pkgver}-linux.tar.xz::https://github.com/frida/frida/releases/download/${pkgver}/frida-core-devkit-${pkgver}-linux-armhf.tar.xz")
source_aarch64=("frida-core-devkit-${pkgver}-linux.tar.xz::https://github.com/frida/frida/releases/download/${pkgver}/frida-core-devkit-${pkgver}-linux-arm64.tar.xz")
-sha256sums=('b2d3a22f8422cd9379ee2a3ca870e50cdb1706cfa48be9587bf835d63e51e582'
+sha256sums=('97d5c3cd0db16a144a769e6f6129671b12dc72e31b6017bc56fc3c9137c2d511'
'5ea1544b51a28bc823b03159190d4108f9fb4f4ef912389f5137c6d295e175b2')
-sha256sums_i686=('00fc9b22d91ed3a1fb18d81ff59626cc1b1835a0752a99d43355f8b977a246c5')
-sha256sums_x86_64=('0b43f204da687d259a84e0374def8b24409aaf4414b2be24bc82954bd34c2111')
-sha256sums_armv7h=('24362b999934c13712cc3439fd538ab538088236e7f139b5b912c2e0976c9958')
-sha256sums_aarch64=('42782f93c2959de5e63759682a89360e8f002f18500099a775f8ecde14f4cc2d')
+sha256sums_i686=('98a8f88fbbbe0d554dd8f2851329e7171b40722555f0c88133c6da82f23ebca0')
+sha256sums_x86_64=('129777ad18e5f7aad94ed689710c2e5e2369cdbfc138e88746a63299838ae0c2')
+sha256sums_armv7h=('a4b71545d882358a23d290b83527bbf0b58cc5dedcb94d51f2a80d1ef3ac8bac')
+sha256sums_aarch64=('e843f1a584cb1900761ccf940788609911c8dda5bf0237d669fe09947cb4f603')
noextract=("frida-core-devkit-${pkgver}-linux.tar.xz")
conflicts=("python2-${_pkgname}")