aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2019-04-26 20:52:01 -0400
committerGI_Jack2019-04-26 20:52:01 -0400
commit99b90e2e02977b79e9fd26dd5123ed537ef3636a (patch)
tree1a9ef989d9310da1d5e3371ae084da239cbee087
parent0542168055b4bf5ccb3a40e17dcbbbc6d6204188 (diff)
downloadaur-99b90e2e02977b79e9fd26dd5123ed537ef3636a.tar.gz
overhauled this package. Units are re-cut from upstream block package, to
follow the original intent of the now ancient previous block hooks. Intent remians to allow the least amount of modules added to get a live os to work. This is intended to keep internal hard disks out of early user space, it boots faster, and gives more control. also added live_virtual for vm guests
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
-rwxr-xr-xlive_firewire21
-rwxr-xr-xlive_mmc19
-rwxr-xr-xlive_usb19
-rwxr-xr-xlive_virtual18
6 files changed, 55 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d90a254bb078..7d86e2ac564a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Apr 26 22:46:10 UTC 2019
+# Sat Apr 27 00:51:52 UTC 2019
pkgbase = mkinitcpio-liveusb-units
pkgdesc = mkinitcpio minimal block hooks for live usb sticks
- pkgver = 1
- pkgrel = 3
+ pkgver = 2
+ pkgrel = 1
url = http://archlinux.org
arch = any
license = GPLv3
@@ -11,9 +11,11 @@ pkgbase = mkinitcpio-liveusb-units
source = live_usb
source = live_mmc
source = live_firewire
- sha256sums = 9a3e21cf18cdcec6e9e7e63ea3037d4914900916dbd8c7106a8ac7208d036d2c
- sha256sums = 2d7f49c80b4230a62adf004a24187cc6aeac75788c70761a178b9ae4ca6fc978
- sha256sums = 4a681d345e55303fc7a9669d644c4dffc9fcad46a2a6dd98075ed281a28662e4
+ source = live_virtual
+ sha256sums = 3f559343cb070ccb77f03fcf54cc2f6a85b763909173dedd2c0aef3394adc7ee
+ sha256sums = 5b4d182584adfc6ec65c9e5c93cf5fff999de08550e3e4ce1483a2e3699bff7c
+ sha256sums = f749ed0ce887f0f59f03c451c5eaa381168c59f389beca8b745fb103c8b13248
+ sha256sums = d6602fae1bdc8981c5121cc8635df10e9e6f99e8ba6bcd20d9af86cf5fd3cf0a
pkgname = mkinitcpio-liveusb-units
diff --git a/PKGBUILD b/PKGBUILD
index 3fb33d7f412a..777b3180dd3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,23 @@
# Maintainer: GI_Jack <iGI_Jack@hackermail.com>
pkgname=mkinitcpio-liveusb-units
-pkgver=1
-pkgrel=3
+pkgver=2
+pkgrel=1
pkgdesc="mkinitcpio minimal block hooks for live usb sticks"
arch=('any')
license=('GPLv3')
url='http://archlinux.org'
depends=('mkinitcpio>=0.12')
-source=('live_usb' 'live_mmc' 'live_firewire')
-sha256sums=('9a3e21cf18cdcec6e9e7e63ea3037d4914900916dbd8c7106a8ac7208d036d2c'
- '2d7f49c80b4230a62adf004a24187cc6aeac75788c70761a178b9ae4ca6fc978'
- '4a681d345e55303fc7a9669d644c4dffc9fcad46a2a6dd98075ed281a28662e4')
+source=('live_usb' 'live_mmc' 'live_firewire' 'live_virtual')
+sha256sums=('3f559343cb070ccb77f03fcf54cc2f6a85b763909173dedd2c0aef3394adc7ee'
+ '5b4d182584adfc6ec65c9e5c93cf5fff999de08550e3e4ce1483a2e3699bff7c'
+ 'f749ed0ce887f0f59f03c451c5eaa381168c59f389beca8b745fb103c8b13248'
+ 'd6602fae1bdc8981c5121cc8635df10e9e6f99e8ba6bcd20d9af86cf5fd3cf0a')
package() {
install -dm755 "${pkgdir}/usr/lib/initcpio/install"
install -m644 "${srcdir}/live_firewire" "${pkgdir}/usr/lib/initcpio/install/live_firewire"
install -m644 "${srcdir}/live_usb" "${pkgdir}/usr/lib/initcpio/install/live_usb"
install -m644 "${srcdir}/live_mmc" "${pkgdir}/usr/lib/initcpio/install/live_mmc"
+ install -m644 "${srcdir}/live_virtual" "${pkgdir}/usr/lib/initcpio/install/live_virtual"
}
diff --git a/live_firewire b/live_firewire
index d8c7d8f8a393..95124927c6c6 100755
--- a/live_firewire
+++ b/live_firewire
@@ -1,22 +1,15 @@
#!/bin/bash
-
-build() {
- local filter
- local -A blockdevs
- blockdevs+=(['usb_storage?']=1 ['sd_mod?']=1 ['sr_mod?']=1)
- add_checked_modules 'drivers/usb/storage/ums-*'
- fi
-
- firewire
- if add_checked_modules '/drivers/firewire/'; then
- blockdevs+=(['firewire-sbp2?']=1 ['sd_mod?']=1 ['sr_mod?']=1)
- fi
+build(){
+ map add_module firewire-sbp2?
+ # firewire
+ add_checked_modules '/drivers/firewire/'
}
help() {
cat <<HELPEOF
-This hook loads the necessary modules for most block devices using firewire. Detection will take place at runtime. To minimize
-the modules in the image, add the autodetect hook too.
+This hook loads the necessary modules for most block devices using firewire.
+Detection will take place at runtime. To minimize the modules in the image, add
+the autodetect hook too.
HELPEOF
}
diff --git a/live_mmc b/live_mmc
index 7783489567de..1bf67def728e 100755
--- a/live_mmc
+++ b/live_mmc
@@ -1,20 +1,15 @@
#!/bin/bash
-
-build() {
- local filter
- local -A blockdevs
-
- mmc
- if add_checked_modules '/mmc'; then
- blockdevs+=(['tifm_7xx1?']=1 ['mmc_block?']=1)
- fi
- map add_module "${!blockdevs[@]}"
+build(){
+ # mmc
+ map add_module mmc_block?
+ add_checked_modules '/(mmc|tifm_)'
}
help() {
cat <<HELPEOF
-This hook loads the necessary modules for most block devices using mmc. Detection will take place at runtime. To minimize
-the modules in the image, add the autodetect hook too.
+This hook loads the necessary modules for most block devices using mmc.
+Detection will take place at runtime. To minimize the modules in the image, add
+the autodetect hook too.
HELPEOF
}
diff --git a/live_usb b/live_usb
index edbbae85363b..8abbe06444a1 100755
--- a/live_usb
+++ b/live_usb
@@ -1,22 +1,17 @@
#!/bin/bash
-
-build() {
- local filter
- local -A blockdevs
-
+build(){
+ map add_module usb_storage? sd_mod?
# usb
- if add_checked_modules -f '(_cs|sl811_hcd|isp116x_hcd)' '/usb/host'; then
- blockdevs+=(['usb_storage?']=1 ['sd_mod?']=1 ['sr_mod?']=1)
- add_checked_modules 'drivers/usb/storage/ums-*'
- fi
+ add_checked_modules -f '(_cs|sl811_hcd|isp116x_hcd)' '/usb/host'
+ add_checked_modules '/drivers/usb/storage/'
- map add_module "${!blockdevs[@]}"
}
help() {
cat <<HELPEOF
-This hook loads the necessary modules for usb block devices. Detection will take place at runtime. To minimize
-the modules in the image, add the autodetect hook too.
+This hook loads the necessary modules for usb block devices. Detection will take
+place at runtime. To minimize the modules in the image, add the autodetect hook
+too.
HELPEOF
}
diff --git a/live_virtual b/live_virtual
new file mode 100755
index 000000000000..c088ed5e7f57
--- /dev/null
+++ b/live_virtual
@@ -0,0 +1,18 @@
+#!/bin/bash
+
+build(){
+ map add_module virtio_blk? sd_mod?
+ # virtio
+ add_checked_modules 'virtio'
+}
+
+help() {
+ cat <<HELPEOF
+This hook loads the necessary modules for virtual machine block devices.
+Detection will take place at runtime. To minimize the modules in the image, add
+the autodetect hook too.
+HELPEOF
+}
+
+# vim: set ft=sh ts=4 sw=4 et:
+