summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée2015-07-08 18:16:51 +0200
committerMattias Andrée2015-07-08 18:16:51 +0200
commit99befc5666cac0d67d0fa5b3e07dba4eb9573071 (patch)
tree64feab1d63cc02830ac5d42c4c0109c251bcc65b
downloadaur-99befc5666cac0d67d0fa5b3e07dba4eb9573071.tar.gz
Initial import, version 1506171755
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97717fe2a265
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = fortune-mod-lostgirl
+ pkgdesc = Fortune quotes from Lost Girl
+ pkgver = 1506171755
+ pkgrel = 1
+ url = http://en.wikiquote.org/wiki/Lost_Girl
+ arch = any
+ license = custom:cc-sa-3.0
+ makedepends = fortune-mod
+ makedepends = make
+ makedepends = coreutils
+ makedepends = sed
+ makedepends = grep
+ makedepends = wikiquote-fortune>=1.4
+ depends = fortune-mod
+ source = https://github.com/maandree/wikiquote-fortune-collection/archive/5.tar.gz
+ sha256sums = f25b0e335782fc59bf960e5f09c16ebd0bd38cb9cb174f0338c6ba5f8d3013b5
+
+pkgname = fortune-mod-lostgirl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49f93040d48a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=fortune-mod-lostgirl
+pkgver=1506171755
+pkgrel=1
+_ver=5
+pkgdesc="Fortune quotes from Lost Girl"
+arch=('any')
+license=('custom:cc-sa-3.0')
+url=("http://en.wikiquote.org/wiki/Lost_Girl")
+depends=('fortune-mod')
+makedepends=('fortune-mod' 'make' 'coreutils' 'sed' 'grep' 'wikiquote-fortune>=1.4')
+source=("https://github.com/maandree/wikiquote-fortune-collection/archive/${_ver}.tar.gz")
+sha256sums=(f25b0e335782fc59bf960e5f09c16ebd0bd38cb9cb174f0338c6ba5f8d3013b5)
+
+
+build()
+{
+ cd "${srcdir}/wikiquote-fortune-collection-${_ver}"
+ make SHOWS=lostgirl SCRIPTS=
+}
+
+package()
+{
+ cd "${srcdir}/wikiquote-fortune-collection-${_ver}"
+ cd quotes/lostgirl
+ install -dm755 -- "${pkgdir}/usr/share/fortune"
+ install -m644 -- lostgirl lostgirl.dat "${pkgdir}/usr/share/fortune"
+}
+