summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMicha Alt2015-06-08 15:35:28 +0200
committerMicha Alt2015-06-08 15:35:28 +0200
commit99c39d0388bc4040a2a7b0174222ca507ae6cb45 (patch)
tree177b1ca4780baa63884b2add490e8f9aac8e6cda
downloadaur-99c39d0388bc4040a2a7b0174222ca507ae6cb45.tar.gz
Initial commit: nodejs-brunch 1.8.3-1
-rw-r--r--.SRCINFO17
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD29
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38b6c7ac2ce3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = nodejs-brunch
+ pkgdesc = A lightweight approach to building HTML5 applications with emphasis on elegance and simplicity.
+ pkgver = 1.8.3
+ pkgrel = 1
+ url = http://brunch.io/
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ noextract = brunch-1.8.3.tgz
+ source = http://registry.npmjs.org/brunch/-/brunch-1.8.3.tgz
+ source = LICENSE
+ sha1sums = d0103b4799f09eabecdb8ca9dd65236b375badd6
+ sha1sums = de1abc751d24ab2b3ee1dff74f86aeeaee3854b3
+
+pkgname = nodejs-brunch
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ae1e69d6a4a9
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,20 @@
+Copyright (c) 2011-2015 Allan Berger, Jan Monschke, Martin Schürrer,
+Thomas Schranz, Nik Graf, Paul Miller, Elan Shanker
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17405412032f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: filirom1 <filirom1 at gmail dot com>
+# Maintainer: Micha Alt <micha.tucker at gmail dot com>
+
+_npmname=brunch
+pkgname=nodejs-$_npmname
+pkgver=1.8.3
+pkgrel=1
+pkgdesc="A lightweight approach to building HTML5 applications with emphasis on elegance and simplicity."
+arch=('any')
+url="http://brunch.io/"
+license=('MIT')
+depends=('nodejs' )
+makedepends=('npm' )
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz
+ 'LICENSE')
+noextract=($_npmname-$pkgver.tgz)
+sha1sums=('d0103b4799f09eabecdb8ca9dd65236b375badd6'
+ 'de1abc751d24ab2b3ee1dff74f86aeeaee3854b3')
+
+package() {
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install --user root -g --prefix "$pkgdir/usr" $_npmname@$pkgver
+}