summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Bruckner2015-06-08 03:06:46 +0200
committerMax Bruckner2015-06-08 12:19:11 +0200
commit99c75da6914a4c6f9f3a8ee4c902381b6ab9b6ae (patch)
tree1b09a3d6c99176ece0010ea616cd99c65b5ddef2
downloadaur-99c75da6914a4c6f9f3a8ee4c902381b6ab9b6ae.tar.gz
1.3.0-1: Initial version
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8186862dfa2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = easyhg
+ pkgdesc = Simple user interface for the Mercurial distributed version contol system.
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = http://easyhg.org
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = qt4
+ depends = mercurial
+ optdepends = pyqt: authentication extension
+ optdepends = python-crypto: password store
+ optdepends = kdiff3: external diff/merge tool
+ source = https://code.soundsoftware.ac.uk/attachments/download/639/EasyMercurial-1.3.0-src.tar.gz
+ md5sums = 728858917b2b121e2ee7ce160ff4151f
+
+pkgname = easyhg
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f52b2f5a9940
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.xz
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4cc99af0917
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Max Bruckner
+pkgname=easyhg
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Simple user interface for the Mercurial distributed version contol system."
+arch=('i686' 'x86_64')
+url="http://easyhg.org"
+license=('GPL2')
+depends=('qt4' 'mercurial')
+optdepends=('pyqt: authentication extension'
+'python-crypto: password store'
+'kdiff3: external diff/merge tool')
+source=(https://code.soundsoftware.ac.uk/attachments/download/639/EasyMercurial-1.3.0-src.tar.gz)
+md5sums=('728858917b2b121e2ee7ce160ff4151f')
+
+build() {
+ cd "$srcdir/EasyMercurial-1.3.0-src"
+ qmake-qt4
+ make
+}
+
+package() {
+ cd "$srcdir/EasyMercurial-1.3.0-src"
+ mkdir "$pkgdir/usr"
+ mkdir "$pkgdir/usr/bin"
+ cp EasyMercurial "$pkgdir/usr/bin/easyhg"
+}