summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmin Vakil2021-02-27 00:56:50 +0330
committerAmin Vakil2021-02-27 00:56:50 +0330
commit99cd8b6869e4d9619ca0f65d8be4740f0f5e4c0d (patch)
tree5324cd9e5006c1ad5cbbe765c8e965ab79969d43
parent35a6c8d98727ba01518e8aba03385f31cdb37974 (diff)
downloadaur-99cd8b6869e4d9619ca0f65d8be4740f0f5e4c0d.tar.gz
KISS
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD83
-rw-r--r--gschemas.install20
3 files changed, 14 insertions, 97 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81b774d9afff..b14b44eb3b3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,18 +3,14 @@ pkgbase = gnome-shell-extension-dash-to-dock-git
pkgver = 69.r11.g7a2c87b
pkgrel = 1
url = https://micheleg.github.io/dash-to-dock/
- install = gschemas.install
arch = any
license = GPL
- makedepends = intltool
makedepends = git
- depends = dconf
- depends = gnome-shell
depends = gnome-shell
provides = gnome-shell-extension-dash-to-dock
conflicts = gnome-shell-extension-dash-to-dock
- source = gnome-shell-extension-dash-to-dock::git+https://github.com/micheleg/dash-to-dock/
- md5sums = SKIP
+ source = git+https://github.com/micheleg/dash-to-dock.git
+ sha256sums = SKIP
pkgname = gnome-shell-extension-dash-to-dock-git
diff --git a/PKGBUILD b/PKGBUILD
index 416afbcf8af1..fbed67a4c392 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,6 +6,7 @@
# This PKGBUILD is maintained on GitHub <https://github.com/dffischer/gnome-shell-extensions>.
# You may find it convenient to file issues and pull requests there.
+_srcname=dash-to-dock
pkgname=gnome-shell-extension-dash-to-dock-git
pkgver=69.r11.g7a2c87b
pkgrel=1
@@ -14,87 +15,27 @@ arch=('any')
url="https://micheleg.github.io/dash-to-dock/"
_giturl="git+https://github.com/micheleg/dash-to-dock/"
license=('GPL')
-depends=('dconf' 'gnome-shell')
-makedepends=('intltool')
+depends=('gnome-shell')
+makedepends=('git')
+conflicts=('gnome-shell-extension-dash-to-dock')
+provides=('gnome-shell-extension-dash-to-dock')
+source=("git+https://github.com/micheleg/${_srcname}.git")
+sha256sums=('SKIP')
-makedepends+=('git')
-source+=("${_gitname:=${pkgname%-git}}::${_giturl:-git+$url}")
-for integ in $(get_integlist)
-do
- typeset -n array="${integ}sums"
- array+=('SKIP')
-done
-provides=("$_gitname")
-conflicts=("$_gitname")
pkgver() {
- cd ${_gitname:-$pkgname}
+ cd "${_srcname}"
git describe --long --tags 2>/dev/null | sed 's/[^[:digit:]]*\(.\+\)-\([[:digit:]]\+\)-g\([[:xdigit:]]\{7\}\)/\1.r\2.g\3/;t;q1'
[ ${PIPESTATUS[0]} -eq 0 ] || \
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$_gitname"
+ cd "${_srcname}"
make VERSION="$pkgver" _build
}
package() {
- for function in $(declare -F | grep -Po 'package_[[:digit:]]+[[:alpha:]_]*$')
- do
- $function
- done
-}
-package_01_locate() {
- echo 'Locating extension...'
- cd "$(find -name 'metadata.json' -execdir test -e extension.js \; \
- -printf '%C@ %h\n' | sort -nr | sed 's/^.* //;q' )"
- extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
- destdir="$pkgdir/usr/share/gnome-shell/extensions/$extname"
-}
-
-package_02_install() {
- echo 'Installing extension code...'
- find -maxdepth 1 \( -iname '*.js*' -or -iname '*.css' -or -iname '*.ui' \) \
- -exec install -Dm644 -t "$destdir" '{}' +
-}
-
-package_09_media() {
- cp -r --no-preserve=ownership,mode media "$destdir"
-}
-
-package_10_locale() {
- echo 'Installing translations...'
- (
- cd locale
- for locale in */
- do
- install -Dm644 -t "$pkgdir/usr/share/locale/$locale/LC_MESSAGES" "$locale/LC_MESSAGES"/*.mo
- done
- )
-}
-if [ -z "$install" ]
-then
- install=gschemas.install
-fi
-
-package_10_schemas() {
- echo 'Installing schemas...'
- find -name '*.xml' -exec install -Dm644 -t "$pkgdir/usr/share/glib-2.0/schemas" '{}' +
-}
-depends[125]=gnome-shell
-
-package_20_version() {
- local compatibles=($(\
- find -path ./pkg -type d -prune -o \
- -name metadata.json -exec cat '{}' \; | \
- tr -d '\n' | grep -Po '(?<="shell-version": \[)[^\[\]]*(?=\])' | \
- tr '\n," ' '\n' | sed 's/3\.//g;/^$/d' | sort -n -t. -k 1,1))
- depends+=("gnome-shell>=3.${compatibles[0]}")
- local max="${compatibles[-1]}"
- if [ "$max" != $(
- gnome-shell --version | grep -Po '(?<=GNOME Shell 3\.)[[:digit:]]+'
- ) ]; then
- depends+=("gnome-shell<3.$((${max%%.*} + 1))")
- fi
- unset depends[125]
+ cd "${_srcname}"
+ make
+ make install
}
diff --git a/gschemas.install b/gschemas.install
deleted file mode 100644
index 863897ad5436..000000000000
--- a/gschemas.install
+++ /dev/null
@@ -1,20 +0,0 @@
-post_install() {
- instruct
- echo "and enable the extension with gnome-tweak-tool."
-}
-
-post_upgrade() {
- instruct
- echo "for the changes to have an effect."
-}
-
-post_remove() {
- glib-compile-schemas usr/share/glib-2.0/schemas/
-}
-
-instruct() {
- post_remove
- echo "Don't forget to restart GNOME Shell ([Alt]+[F2], r)"
-}
-
-# vim: ts=2 sw=2 et: