summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2021-12-09 15:59:24 +0800
committerUniversebenzene2021-12-09 15:59:24 +0800
commit99d4f23439695345808698995ce4082ebd875567 (patch)
treeeacb068fddbf4d78e90768923e4f2a544ee5f78e
parent95f8e509f56ed60d31f64b4520883a83af694996 (diff)
downloadaur-99d4f23439695345808698995ce4082ebd875567.tar.gz
Update to version 0.16.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f67b9b9d076..a1e54a04f644 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,23 @@
pkgbase = python-poliastro
pkgdesc = Astrodynamics and Orbital Mechanics computations
- pkgver = 0.15.2
+ pkgver = 0.16.0
pkgrel = 1
url = http://docs.poliastro.space
- arch = i686
- arch = x86_64
+ arch = any
license = MIT
makedepends = python-setuptools
makedepends = python-dephell
- source = https://files.pythonhosted.org/packages/source/p/poliastro/poliastro-0.15.2.tar.gz
- md5sums = 6f3e724beff0b8831dc3101acfadb633
+ source = https://files.pythonhosted.org/packages/source/p/poliastro/poliastro-0.16.0.tar.gz
+ md5sums = 37e9d40c6190e8ca765c57adb727d176
pkgname = python-poliastro
depends = python-scipy
depends = python-astropy
depends = python-jplephem
- depends = python-matplotlib
+ depends = python-matplotlib>3.0.1
depends = python-plotly
- optdepends = python-numba: For accelerating the code
+ depends = python-numba>=0.53.0
optdepends = python-poliastro-doc: Documentation for poliastro
optdepends = python-pandas
- optdepends = python-astroquery
+ optdepends = python-astroquery>=0.3.9
optdepends = python-pytest: For running the tests from the package
diff --git a/PKGBUILD b/PKGBUILD
index 5913f64dec44..2b570690d07c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-poliastro
_pyname=${pkgname#python-}
-pkgver=0.15.2
+pkgver=0.16.0
pkgrel=1
pkgdesc="Astrodynamics and Orbital Mechanics computations"
-arch=('i686' 'x86_64')
+arch=('any')
url="http://docs.poliastro.space"
license=('MIT')
makedepends=('python-setuptools' 'python-dephell')
@@ -21,7 +21,7 @@ makedepends=('python-setuptools' 'python-dephell')
# 'python-jplephem'
# 'python-numba')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('6f3e724beff0b8831dc3101acfadb633')
+md5sums=('37e9d40c6190e8ca765c57adb727d176')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -43,12 +43,12 @@ build() {
#}
package() {
- depends=('python-scipy' 'python-astropy' 'python-jplephem' 'python-matplotlib' 'python-plotly')
+ depends=('python-scipy' 'python-astropy' 'python-jplephem' 'python-matplotlib>3.0.1' 'python-plotly' 'python-numba>=0.53.0')
#'python-retrying')
- optdepends=('python-numba: For accelerating the code'
- 'python-poliastro-doc: Documentation for poliastro'
+ optdepends=('python-poliastro-doc: Documentation for poliastro'
+# 'python-numba: For accelerating the code'
'python-pandas'
- 'python-astroquery'
+ 'python-astroquery>=0.3.9'
'python-pytest: For running the tests from the package')
cd ${srcdir}/${_pyname}-${pkgver}