summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJia Li2016-08-16 14:19:50 -0400
committerJia Li2016-08-16 14:19:50 -0400
commit99df83d7dc1a0a4a37582d910b77cedeb61e825e (patch)
tree2b06f1456014742f433024b1cc88602fe6262a29
downloadaur-99df83d7dc1a0a4a37582d910b77cedeb61e825e.tar.gz
Init
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD26
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89e2ee5c810b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = alpscore-openmpi
+ pkgdesc = ALPS Core libraries for numerical simulations of condensed matter systems.
+ pkgver = 0.5.4
+ pkgrel = 1
+ url = http://alpscore.org
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = cmake
+ depends = boost
+ depends = hdf5
+ depends = openmpi
+ provides = alpscore-openmpi=0.5.4
+ conflicts = alpscore-git
+ conflicts = alpscore
+ conflicts = alpscore-openmpi-git
+ conflicts = alps
+ source = https://github.com/ALPSCore/ALPSCore/archive/v0.5.4.tar.gz
+ md5sums = b887c9328e2a22afa123663cf888b768
+
+pkgname = alpscore-openmpi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..736bb81bdb98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jia Li <lijia1608@gmail.com>
+pkgname=alpscore-openmpi
+pkgver=0.5.4
+pkgrel=1
+pkgdesc="ALPS Core libraries for numerical simulations of condensed matter systems."
+arch=(i686 x86_64)
+url="http://alpscore.org"
+license=('GPL2')
+depends=('cmake' 'boost' 'hdf5' 'openmpi')
+provides=($pkgname=$pkgver)
+conflicts=(alpscore-git alpscore alpscore-openmpi-git alps)
+source=("https://github.com/ALPSCore/ALPSCore/archive/v$pkgver.tar.gz")
+md5sums=('b887c9328e2a22afa123663cf888b768')
+
+build() {
+ cd "ALPSCore-$pkgver"
+ mkdir -p build
+ cd build
+ CC=mpicc CXX=mpicxx cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DTesting=OFF -DDocumentation=OFF ..
+ make
+}
+
+package() {
+ cd "ALPSCore-$pkgver/build"
+ make DESTDIR="$pkgdir/" install
+}