summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Klitzing2023-10-17 10:00:50 +0200
committerAndré Klitzing2023-10-17 10:00:50 +0200
commit99ebe97988f027679bab5a243634ef67f8e22acc (patch)
tree7d6fecd86013396dc6d6372f6f10d83e16cd2987
parent1bd0810c863a010c65469e461370437772dd7dc3 (diff)
downloadaur-99ebe97988f027679bab5a243634ef67f8e22acc.tar.gz
Fix GUI with Qt 6.6
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--qml.patch41
3 files changed, 49 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f3d316e1019..199d7512b161 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ausweisapp2
pkgdesc = A software application that you install on your computer to use your national identity card or your electronic residence permit for online identification
pkgver = 1.26.7
- pkgrel = 2
+ pkgrel = 3
url = https://www.ausweisapp.bund.de/
arch = i686
arch = x86_64
@@ -24,9 +24,11 @@ pkgbase = ausweisapp2
source = https://github.com/Governikus/AusweisApp2/releases/download/1.26.7/AusweisApp2-1.26.7.tar.gz
source = https://github.com/Governikus/AusweisApp2/releases/download/1.26.7/AusweisApp2-1.26.7.tar.gz.asc
source = qt66.patch
+ source = qml.patch
validpgpkeys = 699BF3055B0A49224EFDE7C72D7479A531451088
sha256sums = 8062fe04332e9a7bee4c75fe3ef3efda6748c1a19a6fda8770f7914939c7bd28
sha256sums = SKIP
sha256sums = 59beebd6777d772488dc371dd85f9c28d554c480d0c094ee05b463b17cd1f0d6
+ sha256sums = d00b62baebddfb643a67df2ab088efc388fe2a87a195b5b293087dacad261a34
pkgname = ausweisapp2
diff --git a/PKGBUILD b/PKGBUILD
index d8c473437788..50c7e3592c05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ausweisapp2
pkgver=1.26.7
-pkgrel=2
+pkgrel=3
pkgdesc="A software application that you install on your computer to use your national identity card or your electronic residence permit for online identification"
arch=('i686' 'x86_64' 'aarch64')
license=('custom:EUPL1.2')
@@ -10,15 +10,17 @@ url="https://www.ausweisapp.bund.de/"
depends=('qt6-declarative' 'qt6-svg' 'qt6-websockets' 'qt6-scxml' 'pcsclite' 'http-parser')
makedepends=('cmake' 'qt6-tools' 'qt6-shadertools' 'ninja' 'pkgconf')
optdepends=('ccid' 'acsccid' 'pcsc-cyberjack')
-source=("https://github.com/Governikus/AusweisApp2/releases/download/${pkgver}/AusweisApp2-${pkgver}.tar.gz"{,.asc} "qt66.patch")
+source=("https://github.com/Governikus/AusweisApp2/releases/download/${pkgver}/AusweisApp2-${pkgver}.tar.gz"{,.asc} "qt66.patch" "qml.patch")
validpgpkeys=('699BF3055B0A49224EFDE7C72D7479A531451088')
sha256sums=('8062fe04332e9a7bee4c75fe3ef3efda6748c1a19a6fda8770f7914939c7bd28'
'SKIP'
- '59beebd6777d772488dc371dd85f9c28d554c480d0c094ee05b463b17cd1f0d6')
+ '59beebd6777d772488dc371dd85f9c28d554c480d0c094ee05b463b17cd1f0d6'
+ 'd00b62baebddfb643a67df2ab088efc388fe2a87a195b5b293087dacad261a34')
prepare() {
cd "AusweisApp2-$pkgver"
patch -p1 -i "$srcdir/qt66.patch"
+ patch -p1 -i "$srcdir/qml.patch"
}
build() {
diff --git a/qml.patch b/qml.patch
new file mode 100644
index 000000000000..c0316e4561f6
--- /dev/null
+++ b/qml.patch
@@ -0,0 +1,41 @@
+diff --git a/resources/qml/Governikus/Global/+desktop/NavigationButton.qml b/resources/qml/Governikus/Global/+desktop/NavigationButton.qml
+--- a/resources/qml/Governikus/Global/+desktop/NavigationButton.qml
++++ b/resources/qml/Governikus/Global/+desktop/NavigationButton.qml
+@@ -64,7 +64,6 @@ Button {
+ }
+ sourceSize.height: Style.dimens.large_icon_size
+ tintColor: Style.color.button_text
+- transformOrigin: Item.Center
+ }
+ GText {
+ anchors.centerIn: parent
+diff --git a/resources/qml/Governikus/Global/TintableIcon.qml b/resources/qml/Governikus/Global/TintableIcon.qml
+--- a/resources/qml/Governikus/Global/TintableIcon.qml
++++ b/resources/qml/Governikus/Global/TintableIcon.qml
+@@ -17,7 +17,6 @@ Item {
+ property alias sourceSize: image.sourceSize
+ property color tintColor: Style.color.primary_text
+ property bool tintEnabled: true
+- property alias transformOrigin: image.transformOrigin
+
+ implicitHeight: image.implicitHeight
+ implicitWidth: image.implicitWidth
+diff --git a/resources/qml/Governikus/Workflow/+mobile/NfcProgressIndicator.qml b/resources/qml/Governikus/Workflow/+mobile/NfcProgressIndicator.qml
+--- a/resources/qml/Governikus/Workflow/+mobile/NfcProgressIndicator.qml
++++ b/resources/qml/Governikus/Workflow/+mobile/NfcProgressIndicator.qml
+@@ -154,7 +154,6 @@ Item {
+ opacity: 0
+ source: "qrc:///images/ausweis.svg"
+ sourceSize.height: phone.height * 0.5
+- transformOrigin: Item.Center
+ visible: !phone.tintEnabled
+ }
+ TintableIcon {
+@@ -175,7 +174,6 @@ Item {
+ rotation: card.rotation
+ source: "qrc:///images/ausweis_outline.svg"
+ sourceSize.height: card.sourceSize.height
+- transformOrigin: Item.Center
+ visible: !phone.tintEnabled
+ x: card.x - phone.x
+ y: card.y - phone.y