summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0b1001002022-01-04 14:51:54 +0100
committer0b1001002022-01-04 14:51:54 +0100
commit99f254e485a7e1d437ee55c9bf286730a99a9706 (patch)
tree7ea1cd96bb68a29cde5cb60243adafd30beca6cc
parentf52ddf2467287cfbdd962a746edb449afcafa35d (diff)
downloadaur-99f254e485a7e1d437ee55c9bf286730a99a9706.tar.gz
Depend on java runtime version >= 8 and remove post install message
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
-rw-r--r--alice-bin.install4
3 files changed, 3 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb5a94bd15a0..9376341b824f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,11 +3,10 @@ pkgbase = alice-bin
pkgver = 3.6.0.2
pkgrel = 1
url = https://www.alice.org
- install = alice-bin.install
arch = i686
arch = x86_64
license = custom
- depends = java-environment=8
+ depends = java-runtime>=8
depends = xdg-utils
depends = lib32-glu
depends = lib32-libxrandr
diff --git a/PKGBUILD b/PKGBUILD
index 9951c1a22d90..695c206d0b34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,14 +12,13 @@ pkgdesc="An educational software that teaches students computer programming in a
arch=('i686' 'x86_64')
url="https://www.alice.org"
license=('custom')
-depends=('java-environment=8'
+depends=('java-runtime>=8'
'xdg-utils'
'lib32-glu'
'lib32-libxrandr'
'lib32-libxcursor')
options=('!strip')
provides=('alice3')
-install=$pkgname.install
source=("$pkgname-$pkgver.sh::https://github.com/TheAliceProject/alice3/releases/download/$pkgver/alice3_unix_installer_${pkgver//./_}+build_$_build.sh")
noextract=("$pkgname-$pkgver.sh")
sha512sums=('6ed9536bb69219e09b7ecb45bfcb163aac6e76260b275fae536dbaeaeb46e3b4c4b71fc0d0ce335da592566322b3131fcf8238c78e9e0661915a084662c6f59d')
@@ -43,4 +42,5 @@ package() {
install -Dm644 "$pkgdir/opt/alice/.install4j/alice3.png" "$pkgdir/usr/share/pixmaps/alice3.png"
install -Dm644 "$pkgdir/opt/alice/application/EULA_Alice3.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+
# vim:set ts=2 sw=2 et:
diff --git a/alice-bin.install b/alice-bin.install
deleted file mode 100644
index e46a77e42fc2..000000000000
--- a/alice-bin.install
+++ /dev/null
@@ -1,4 +0,0 @@
-post_install() {
- echo -e "You need to manually set java-environment=8 by running '\e[32marchlinux-java set java-8-openjdk\e[37m' as root."
- echo "If you have a different package providing Java 8, you can replace the above package with the one you have installed."
-}