summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoris Baum2019-07-16 13:32:47 +0200
committerJoris Baum2019-07-16 13:32:47 +0200
commit99f353c8a7362aa1c5d922ac48fce353686c092f (patch)
treed82ee76d88144a5420812c980d48d5bab138718e
parentab58c560d53329d46ce2aaecf4afd0ddfb6ee545 (diff)
downloadaur-99f353c8a7362aa1c5d922ac48fce353686c092f.tar.gz
Quote variables
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cf229e6b75d..7215d1642f71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = chef-dk-free
- pkgdesc = The Chef development kit contains all the tools you need to develop and test your infrastructure, built by the awesome Chef community.
+ pkgdesc = The Chef development kit contains all the tools you need to develop and test your infrastructure, built by the awesome Chef community. Non-commercial, free distribution.
pkgver = 3.11.3
pkgrel = 1
url = https://downloads.chef.io/chef-dk/
diff --git a/PKGBUILD b/PKGBUILD
index 7a7fd5b174eb..ea097be2390f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=chef-dk-free
pkgver=3.11.3
pkgrel=1
-pkgdesc="The Chef development kit contains all the tools you need to develop and test your infrastructure, built by the awesome Chef community."
+pkgdesc="The Chef development kit contains all the tools you need to develop and test your infrastructure, built by the awesome Chef community. Non-commercial, free distribution."
arch=('x86_64')
url="https://downloads.chef.io/chef-dk/"
license=('Apache')
@@ -18,16 +18,16 @@ package() {
bsdtar -xf data.tar.xz -C "$pkgdir"
# cleanup .git folders, any idea why they are in the package?
- find $pkgdir -type d -name ".git" | xargs rm -rf
+ find "$pkgdir" -type d -name ".git" | xargs rm -rf
# link executables
binaries="berks chef chef-apply chef-shell chef-solo chef-vault cookstyle dco delivery foodcritic inspec kitchen knife ohai push-apply pushy-client pushy-service-manager chef-client"
- mkdir -p $pkgdir/usr/bin
+ mkdir -p "$pkgdir/usr/bin"
for binary in $binaries; do
- ln -s /opt/chefdk/bin/$binary $pkgdir/usr/bin/ || error_exit "Cannot link $binary to /usr/bin"
+ ln -s "/opt/chefdk/bin/$binary" "$pkgdir/usr/bin/" || error_exit "Cannot link $binary to /usr/bin"
done
- chown -Rh 0:0 $pkgdir
- chmod -R 755 $pkgdir/opt
+ chown -Rh 0:0 "$pkgdir"
+ chmod -R 755 "$pkgdir/opt"
}