summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEwout van Mansom2022-01-13 19:02:12 +0100
committerEwout van Mansom2022-01-13 19:02:12 +0100
commit9a190811134cf2c8acaba900a5c84f601bb5e091 (patch)
tree72fad966d0781506109c063dcfe3a5ce40d36417
downloadaur-9a190811134cf2c8acaba900a5c84f601bb5e091.tar.gz
Release initial package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
-rw-r--r--plymouth-theme-ecorp-glitch.install12
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..697519b67899
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = plymouth-theme-ecorp-glitch
+ pkgdesc = E-Corp glitch animation from Mr. Robot scene ported to Plymouth
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/hrshbh/plymouth-themes
+ install = plymouth-theme-ecorp-glitch.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = plymouth
+ source = git+https://github.com/hrshbh/plymouth-themes.git
+ sha256sums = SKIP
+
+pkgname = plymouth-theme-ecorp-glitch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbe7db73cd91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Ewout van Mansom <ewout@vanmansom.name>
+
+pkgname=plymouth-theme-ecorp-glitch
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='E-Corp glitch animation from Mr. Robot scene ported to Plymouth'
+arch=('any')
+url='https://github.com/hrshbh/plymouth-themes'
+license=('GPL3')
+makedepends=('git')
+depends=('plymouth')
+install="${pkgname}.install"
+source=(
+ 'git+https://github.com/hrshbh/plymouth-themes.git'
+)
+sha256sums=('SKIP')
+
+package() {
+ cd "${srcdir}/plymouth-themes/ecorp-glitch"
+
+ install -d "${pkgdir}/usr/share/plymouth/themes/ecorp-glitch"
+ install -Dm 644 * "${pkgdir}/usr/share/plymouth/themes/ecorp-glitch"
+}
diff --git a/plymouth-theme-ecorp-glitch.install b/plymouth-theme-ecorp-glitch.install
new file mode 100644
index 000000000000..8584499913f7
--- /dev/null
+++ b/plymouth-theme-ecorp-glitch.install
@@ -0,0 +1,12 @@
+post_install() {
+ cat <<EOF
+
+==> To activate the theme, run as root:
+==> plymouth-set-default-theme -R ecorp-glitch
+
+EOF
+}
+
+post_upgrade() {
+ post_install $1
+}